3
$\begingroup$

The texture is UV unwrapped properly, and displays properly in the material. However when I try and use it as a density texture for the particle system, it is very messed up. It is rotated off center and the top and bottom are mirrored. Any idea what's going on?

The UVs seem to just get ignored completely as far as I can tell. If I change it to object, and generated etc it changes but if I change it to UVs it stays the same as whatever it was last.

particle settings and UV mapped sphere

I've attached an isolated version of the file below. The particle number is set to 128 instead of 128,000 to bring the size down, make sure to change that to see the issue properly.

$\endgroup$
  • $\begingroup$ I don't see any particles coming out and why did you have the particles as hair, not emitter? $\endgroup$ – LetTheWritersWrite May 23 '17 at 16:45
  • 1
    $\begingroup$ @LetTheWritersWrite The are supposed to remain on the surface. Did you read the text about the particle count? $\endgroup$ – VRM May 23 '17 at 17:25
5
+100
$\begingroup$

You need to be emitting the particles from the Faces not the Vertices.
Think about it, you are trying to control the distribution of the particles with a texture, textures are mapped to the faces.

In the particle settings under the Emission section change the "Emit From:" value to Faces. particle settings

Now if you edit the UV map, you may need to refresh the particle system. You can do that by toggling it to emit from Verts then back to Faces.

That right there takes care of 95% of your problem.
result so far
(I changed the color of the spheres to be red just to show up better)

To fix those last few stragglers, just bump the contrast of the texture up a bit. There are a few pesky gray values in the texture (probably from some island), that is what is making the icospheres appear in the ocean.

Make sure you are changing the particle's texture, not the material's texture.
Open up the Color section and increase the contrast (I found that 1.1 worked fine here.)
particle texture settings

$\endgroup$
  • $\begingroup$ Is there any way to make them display in a grid using this method? $\endgroup$ – VRM May 26 '17 at 15:30
  • $\begingroup$ Figured it out, single particle per face and jitter set to 0 $\endgroup$ – VRM May 26 '17 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.