0
$\begingroup$

I have been working on a short film type scene with full textures and particles of grass, but whenever I add the particles of grass my machine slows down to a snails pace. (I know that working with particles can be tricky because of the load it places on the computer but I have yet to give up.) I have linked in two buildings into my scene and only one is filled with junk (junk linked in with the building), the other is empty.

I have no idea how to make the performance faster, I have tried so many different things to improve it but its not working. I have been to numerous sites and haven't found anything that works. I have even tried converting the grass to separate meshes and joining them together, that made the problem worse.

Once the grass is in my scene it slows the computer down to the point that I can no longer use or move my mouse, and I end up having to restart my computer and start all over repeating the same process over again.

here is my scene in an image. enter image description here

Building with stuff in it. enter image description here

I haven't even added the key elements of the scene yet and I cant do this until this is fixed.

It appears the memory usage slowly creeps to max while preparing to render a single image, and the mouse stops working once its maxed.

Any ideas would be appreciated.

$\endgroup$
  • $\begingroup$ There are options in the particle system that allow hiding a percentage of particles in the viewport without affecting final render quality. Have you tried those? Also you don't need them in view at all times while working, maybe hide them, or put them in another layer $\endgroup$ – Duarte Farrajota Ramos May 23 '17 at 12:47
  • $\begingroup$ Yes, I have tried both of those solutions, but unfortunately the grass is needed to be seen for a short while so I can actually get it placed and with the right amount to cover the ground,but it seems to still be slow after hiding the grass and adding the key elements. $\endgroup$ – Kaylee Jacobs May 23 '17 at 14:30
  • $\begingroup$ Also I can only add so much to the scene before it slows down the render to the point that it actually won't render in a reasonable amount of time, and take up to 24 hours to finish three frame in an animation. Imagine that with 327 frames! $\endgroup$ – Kaylee Jacobs May 23 '17 at 14:37
  • $\begingroup$ Well you never state your computer specs, so we can't tell if it is an issue or just natural limits, but as a wise man once said: "Invest in new hardware to match your expectations, or lower your expectations to match your current hardware" $\endgroup$ – Duarte Farrajota Ramos May 23 '17 at 15:18
  • $\begingroup$ I am currently working on a quad core with 6GB and have been needing to upgrade to something faster. I am not completely sure what spec machine would be appropriate for a stand alone workstation. If you could suggest a hardware spec and video card option that won't break the bank that would be helpful. $\endgroup$ – Kaylee Jacobs May 23 '17 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.