1
$\begingroup$

I use Blender 2.78c in Experimental feature set. In order to use microdisplacement I added subsurf to my object but set everywhere mean crease 1.00 for preserving original shape. But when I do preview render something goes wrong and my honeycomb being deformed. Honeycomb Settings Render

$\endgroup$
  • 1
    $\begingroup$ And you've confirmed that this only happens when using experimental microdisplacement? Also, does disabling experimental features resolve the red warning indicator in your SubSurf Modifier? $\endgroup$ – Mentalist May 22 '17 at 15:06
  • $\begingroup$ Disabling experimental mode resolves the problem. But subsurf red background title disappears when I add 1 subdivision level. Also when I turn subsurf more than five it looks better but it is too much geometry. I would like keep polygons low and keep experimental because I need microdisplacement. $\endgroup$ – Random generalist May 22 '17 at 15:17
  • $\begingroup$ Honeycomb also divide this square into 2 faces. I was thinking about cutting this faces to smooth geometry but I can't cut them! $\endgroup$ – Random generalist May 22 '17 at 15:24
  • $\begingroup$ Can you upload the .blend to Blend Exchange? $\endgroup$ – Mentalist May 22 '17 at 15:26
  • 2
    $\begingroup$ The problem is probably in ngons. They don't subsurf well. Break them into triangles and it should fix it. $\endgroup$ – Jaroslav Jerryno Novotny May 22 '17 at 20:55
1
$\begingroup$

Cutting faces works well. Ngons were a problem.enter image description here enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.