2
$\begingroup$

After I moving Blender to the 'Applications' directory it works fine. The trouble starts when another user with his/her own account on the Mac wants to run Blender too when logged-in to his/her account. Then it tells you that you don't have the right permissions to open the Application 'Blender'.

I am not new to Linux/Unix permissions and have tried to set the permissions, but even if I set it to world-readable/writable/executable, it still doesn't.

(Mac OS Sierra)

$\endgroup$
2
  • $\begingroup$ What appears as a mac application is a folder, are you applying permissions recursively so that the binary and other files inside the app folder that are needed to open are also set? $\endgroup$
    – sambler
    May 23, 2017 at 1:55
  • $\begingroup$ I have tried that too. chmod -R o+rwx Still no possibility to run it in a different user account $\endgroup$
    – Chris V
    May 23, 2017 at 12:18

1 Answer 1

1
$\begingroup$

Having tried many more things, what finally worked was:

Changing the ACL permissions of the Applications/Blender directory through finder with the 'Get info' option and set use the 'Apply to enclosed items' option in there (cog wheel icon at the bottom, once you've changed a permission setting).

Even though in there I set the specific user to allow read and write (even using 'Apply to enclosed items' before, it did not do the trick. Only when I allowed staff to do this, it worked. Yet that user was not a member of the group 'staff'. So even though this worked, I don't really understand why this worked.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .