2
$\begingroup$

This question already has an answer here:

I am learning how to use blender for motion graphics, and I wanted to create a sort of blur-to-fade effect, and now I am trying to blur one object (with nodes) but I fail in getting the right composition of the render layers.

I have a scene with two cubes, each on different layers, each layer as a separated render layer.

Using nodes, I use the two render layers as inputs, I blur one and leave the other as-is. Then I want to compose the output so that only the objects are composed (one object over the other), but apparently both images, including backgrounds, are mixed.

I tried to use Alpha Over, to my understanding it should work only on alphas of the image, but it seems to work on colors in some way.

I am using Cycles to render, and the world background has no alpha in the color, but I tried changing it and there is no difference in the output.

Here's a screenshot with the set-up.

blender setup trying to blur an object with nodes

Note in the bottom-left corner that the two cubes are overlapping: that is happening because I am using Fac = 0.8 in the Alpha Over node, but if I leave it to 1.0, I can see only the non-blurred cube and the other is hidden. If I use Fac = 0.0 I can see only the blurred.

I thought that Alpha Over would mix the images using only alpha channel, disregarding the red background, but obviously I am doing something wrong, because they are mixed with the background as well.

Where am I doing wrong? I hope it's clear what I want to achieve.

EDIT:

I tried following this video, and I basically want to get the same result.

$\endgroup$

marked as duplicate by Community May 19 '17 at 22:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    $\begingroup$ Check "Transparent" in the Film tab of the render settings to get a transparent background. $\endgroup$ – Scott Milner May 19 '17 at 22:03
1
$\begingroup$

The alpha over node ONLY works on alpha. To blend them correctly, the layer you are putting on top needs a transparent background. To do this, you can render with a transparent background.

Properties Editor > Render Context > Film Panel

Check Transparent so that the World background is transparent.

Saving PNG with alpha using Cycles

Taken from: https://blender.stackexchange.com/a/1307/3127

Next, you need to reassemble your composite, with the background. The best way I could find of doing this is to create a separate render layer to capture the environment background:

And then combine the two layers on top of it:

enter image description here

$\endgroup$
2
$\begingroup$

Check "Transparent" in the Film tab of the render settings to get a transparent background.

enter image description here

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.