In unity3d i make GameObject > 3D Object > Cylinder And this Cylinder have the components: Cylinder (Mesh Filter), Capsule Collider, Mesh Renderer. I can add the last 2 components to my exported Cylinder from blender but i can't add the Cylinder (Mesh Filter) component. What is Cylinder (Mesh Filter) ? It's just a Mesh Filter component ?

Now i have some problems. I created some Cylinders in blender. All of them i did using Knife Project. And the last step was to click on Delete > Faces. If i'm not clicking on Delete and make delete faces it will not cut the hole.

The first problem is in the first cylinder i created in blender i cut a simple circle hole and it's working fine exported it to unity3d. But the next cylinders i exported for some reason when i'm looking at them from the front they are hollow i see the other side outside but if i'm moving around from the back it's not hollow. Not sure why.

In this screenshot the cylinders i exported and that are in unity3d. The one that is fine is on the left. The others on the right hollow like the hole cut was to the other side but if i will look from behind it's not open in the back:

Cylinders front

And back

Cylinders back

In general my main goal is to create a cylinder in blender with a hole but big enough like in the first screenshot the right cylinders so i can walk in with my character. But the cylinders should be like those in unity3d but with a hold so i can walk in.

  • $\begingroup$ I think this is more Unity related than Blender related $\endgroup$
    – J Sargent
    Commented May 14, 2017 at 19:17
  • $\begingroup$ Maybe recalculate normals (Edit mode > select all > Ctrl+N). $\endgroup$
    – Mr Zak
    Commented May 14, 2017 at 19:34

1 Answer 1


I can't say for certain from the information you've provided, but I suspect that the first cylinder, with the holes through both sides, was created by doing a knife project through the cylinder in wireframe mode, and cut the hole through both sides of the cylinder. I suspect that the other cylinders you made, you used knife project in a different mode, and that the knife project tool only cut the closest surface. To get the hole in the back side, you could either switch to wireframe shading before you do the knife cut, or do the knife cut twice, one for each side. The reason you can see through the wall on the opposite side of your cylinder is because you're looking through the back side of the far wall.

By default, Blender does not use double sided faces, a consequence of which is that in most circumstances, when you look from the backside of a Blender plane, it will not be visible. There are a number of ways that you can address this issue. One is to create extra geometry, so that your cylinder is "double walled", another is to enable double sided faces, as detailed in the answer to this question on Blender stack exchange.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .