1
$\begingroup$

Relatively new to Blender, completely new to stack exchange.

Creating a dimly lit scene using a large amount of emissive objects. Render keeps coming up with tons of fireflies in it. example Scene is dark so you might have to zoom in a bit.

Tried multiple methods including, increasing samples, changing clamp settings, caustics, filter glossy, among many other things, none of which seemed to fix it in the slightest. Is there anything else I could try or have I incorrectly used the previous methods?

Any help would be appreciated!

Here's the file.

$\endgroup$
0
$\begingroup$

enter image description hereHi there, I checked your file and you had a few weird things going on... In order of importance.

You had too many emission objects with different values, the problem here is that some meshes are very small and have a high emission value (strength).

I fixed it and replaced all emission materials with only 2, one for the houses and the other for the electricity rays. I think i screwed up your animation there :(

also the world background was only contributing noise to the scene because of the texture you applied to it, and the background was basically black so I just removed the texture and made it all black and saved some render time.

Other than that the scene looks fine.

Some optimizations I made... Organized your scene since It has a lot of objects. using "3D view:Layer Management" comes with blender, just turn it on.

I also used Branch Path Tracing and saved a ton of time rendering.

I noticed you have a crazy high resolution at 60 fps if you are going to render an animation just double check the settings and make sure that's what you really want, if you are using a GPU to render change the tile size back to 256, if you are using a CPU keep it at 32... that's the size I used to render your image.

Good luck with your project!

https://drive.google.com/file/d/0B7Is78yvd9nWa2wtVHVaT21Hb28/view?usp=sharing

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Hey! Thanks, your tips helped a ton and fixed the problem. Wasn't sure how to gauge emission strength so I was setting it to absurdly high numbers and just going off how much it lit up the objects around it. $\endgroup$ – huntybunty May 9 '17 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.