0
$\begingroup$

I have a problem with my UV Mapping.

I made the Texture Map as usual, but sometimes, some faces do not take the texture from the specific area in the Texture Map but others.

The software I'm using is DSMODT, a Mod Tool for Dark Souls 1. Here is the list of screenshots: https://imgur.com/a/C2oRQ

Example of the problem

enter image description here

So what I did was to isolate the specific area : enter image description here

And put my texture in the little isolated corner : xf

But the issue stays the same. This faces are textured with the big wood and gold square of the texture map file.

Why, is it a problem in Blender or did I do something wrong?

I'm sorry, I'm not an English speaker and I don't really know the good vocabulary to use.

$\endgroup$
  • $\begingroup$ How many materials are applied to your object? Is the correct material slot assigned to those faces? What happens when you open that texture in the UV/Image Editor, do the faces still match the correct part of image? Judging from the ingame screenshot stretching, it looks like those faces aren't unwrapped at all, are you sure those are the faces in question? $\endgroup$ – Duarte Farrajota Ramos May 9 '17 at 0:03
  • $\begingroup$ Abject, the first thing that came to my mind when I read your question is that maybe the faces which do not seem to be taking the textures have the normals flipped, so that while the faces are textured, the texture is facing the inside of the mesh. If this is the case, try flipping the normals for those faces. $\endgroup$ – brasshat May 9 '17 at 1:19
  • $\begingroup$ @brasshat Thank you for your answer ! I flipped the normals to see if it was the problem, but it wasn't :'( $\endgroup$ – Abject May 9 '17 at 2:32
  • $\begingroup$ @DuarteFarrajotaRamos Thank you for your answer ! First of all, I do the 3D models in Sketchup, I then export them in ".dae" files before importing them in Blender. I only use Blender for the Armature and the Texturing. Therefore, I don't really know what the material have to do with it for example :/ I tried to select all my meshes and to "Assign" the material. Is it the right thing to do ? Because it doesn't solve the problem. And yes I'm sure those are the faces in question :'( $\endgroup$ – Abject May 9 '17 at 2:32
  • $\begingroup$ Abject, you may find it useful to upload your ~.blend file to <blend-exchange.giantcowfilms.com> and edit the link top the blend file into your answer. I don't speak for anyone else, but I can't help anymore with the information thus far provided. $\endgroup$ – brasshat May 9 '17 at 2:50
0
$\begingroup$

Problem Solved !
Your answers helped me thinking another way I was thinking at first.
Some polygons were just weirdly imported from my Sketchup model.
I learned two new features : the "L" key, and the "Make Edge/Face".
Both helped me to see where were the problems with my polygons.

My Shovel Knight is now complete ! enter image description here

Praise the sun ! [T]/

$\endgroup$
  • $\begingroup$ I cannot accept my own answer in less than two days... WTF ? Anyway, how can mark this post as solved ? $\endgroup$ – Abject May 9 '17 at 6:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.