0
$\begingroup$

I'm using Blender 2.78. I choose CUDA (Nvidia Geforce 940MX) as compute device in User preferences > System > compute device.
But everytime I render, blender uses CPU instead of Graphic card for rendering.enter image description here

Then, I searched around the web, and I found out there is an option to choose render device in property window in others, but not mine (As shown in picture). Is there any other way to use GPU for rendering, or is there any other option to choose render device.

P.S
Geforce 940MX support CUDA.
My graphic memory is more than rendering memory.
I already chose CUDA as compute device and made default, in user preferences.
I have latest graphic driver.
I am using Windows 10 v1703.
I tried to run as administrator and run with graphic processor.
Thanks.
Alexander Beatson

$\endgroup$
  • $\begingroup$ You will see some CPU usage even when using the GPU to render. You didn't mention, are you using cycles or internal engine? $\endgroup$ – Timaroberts May 8 '17 at 20:10
  • $\begingroup$ What render engine are you using? Only Cycles can use GPU rendering. Also besides the setting in User Preferences you have to actually choose the GPU as device in the render panel. $\endgroup$ – Duarte Farrajota Ramos May 8 '17 at 21:09
  • $\begingroup$ Thank you so much. I used default render engine, and now I change it to cycles. I didn't know only cycles engine support GPU rendering. $\endgroup$ – Alexander Beatson May 8 '17 at 21:25
2
$\begingroup$

Change Blender Render to Cycles Render

$\endgroup$
  • $\begingroup$ Hello and welcome to Blender StackExchange. This is a Q&A forum and you have asked and answered the question yourself in the original post. Also, it helps to add description of the question to help ascertain the need for the question. $\endgroup$ – satishgoda Jul 12 '17 at 15:43
0
$\begingroup$

the same thing happened to me but my solution was quite easy. i had disabled the GPU in it's settings. i turned it back on and everything was ok again.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.