2
$\begingroup$

I'm new here, but this thing is annoying me for at least a whole month. I've searched everywhere and didn't find anything.

If I join 2 body parts, for example the arm and the torso of my character, there will be a kind of line between both, and this happens not only on Blender but on game engines like Unity too, even if the material and the texture are the same.

How can I fix this?

To show an example of this, I split the arm off my character and re-joined it, and there is a division where the mesh was divided. The effect is visible.

Before: before splitting

After: after splitting

$\endgroup$
  • 1
    $\begingroup$ This has nothing to do with textures or materials, this is self intersecting geometry. How did you joint the two objects? Have you removed doubles or welded vertex from the two chunks together afterwards? $\endgroup$ – Duarte Farrajota Ramos May 5 '17 at 4:29
  • 1
    $\begingroup$ Without seeing the mesh (or a blend) it is hard to guess. Be aware when you join two meshes the vertices will not be joined. This means that "smooth shading" will shade the edges as flat (= hard edge) due to the missing "continuation of the mesh". Beside of that changing the topology of one of the meshes (at the contact edges) will make them not fit together. $\endgroup$ – Monster May 5 '17 at 4:30
  • $\begingroup$ I removed the doubles and it worked, thanks! (Saddly the other part just weidly spazzes A LOT, but thanks anyway!) $\endgroup$ – André Morales May 5 '17 at 22:01
1
$\begingroup$

It seems that it is due to the flipped surface. So try to go to the edit mode with face selection mode, then select the face and then click on "Flip Direction" option as shown in screenshot below. enter image description here

$\endgroup$
  • $\begingroup$ This is not due to flipped normals. The seam is visible likely because of different vectors orientation of the normals' vertices on the junction but it is not and should not be fixed with flipping their orientation as will make things worse. $\endgroup$ – Mr Zak Oct 13 '17 at 10:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.