2
$\begingroup$

I'm going to be creating a large number of 2D rectangles with rounded (beveled) corners. I was all set to use Ctrl-Alt-B on the corner vertices of a plane when I found that the bevels created are not truly circular.

By placing a 2x2 plane and then beveling the corners with an offset value=1.0, the resulting mesh should overlay an added mesh circle of the same size. This is not the case. (See image below)

Can anyone suggest a solution or an alternate way to easily create rectangular planes of varying sizes with truly circular corners using specific radii?

Thanks.

enter image description here

$\endgroup$
  • 2
    $\begingroup$ It looks like you changed the Profile value of the bevel. I'd say it's set to somewhere around 0.6. Try setting it to 0.5. $\endgroup$ – Duane Dibbley May 3 '17 at 17:37
  • 1
    $\begingroup$ It might be caused with how you beveled it; to get circle enable Clamp while beveling with C and increase the offset up to maximum. $\endgroup$ – Mr Zak May 3 '17 at 17:54
2
$\begingroup$

Make sure the bevel factor is set to a value of 0.5. Also make sure your object's scale is applied in all axis.

Bevel Factor

Be aware that beveling a 2x2 units plane to a distance of 1 unit will likely create duplicate overlapping vertex at the edge midpoint that may cause problems down the road. It will also turn your four-sided face into a large NGon which is largely regarded as bad practice, and likely to create problems for animation and UV Mapping.

$\endgroup$
  • 1
    $\begingroup$ Thanks to the above commenters and to Duarte for posting as an answer. I had somehow set the Profile value to something other than 0.5 without realizing it. $\endgroup$ – D. Waschow May 3 '17 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.