1
$\begingroup$

Hello Everyone

I'm having an issue with a large project, and although I found a workaround, it's not ideal and I'd like to have a better understand of what is happening.

I've checked a lot of blender crash issues but I couldn't find anything related to this specific situation (it doesn't look like a crash, since it just closes).

I'm working on a complex architecture scene with more than 20 apartments, I got the original file from ArchiCad (or another BIM software) exported as an .obj, and I had no problem importing or whatever, I've been working on it for a couple of months now.

What I'm doing is mostly optimize geometry and UVs, then import each part to UE4 for real time rendering and VR. (just to let you know I'm not rendering in blender).

Due to the complexity of what I want to achieve in UE4, I have to work "on all fronts" and tend to keep different things on different layers, let's say:

Layer:

  • 1 - Keep the original models there (4.7M tris)
  • 2 - the original models with intended location and rotation (4.7M tris)
  • 3 and 4 - mix of the models I'm optimizing (maybe 2M tris)
  • 5, 6, 7 - Junk and not so important parts that might still be useful.

I work almost all the time with layer 3 and 4 on, sometimes I go back and forth to layer 2 to get specific details.

Now, what happens? Blender crashes very often in these situations:

  • 1 - opening the project file - it doesn't open, it closes blender immediately.
  • 2 - leaving the local view - blender closes immediately.
  • 3 - other things like right clicking objects in wireframe mode (doesn't happen very often), let's keep this one as a side note.

I haven't found a solution but here's what I managed to do to be able to work on the file:

Most of the time I can open the file if I left it in local view, I made every object in every layer invisible and then I could leave local view just fine, and make objects visible again, HOWEVER, it still crashed a couple of times doing that.

I got all the objects visible again while in layer 3 and 4, but then I switched to layer 1 again and blender closed again. Then I tested again and it didn't crash.

My knowledge of what is happening is very limited (I know how to drive a car, I know nothing about mechanics or how to build one). But I'm assuming it is something related with this "loading" and "reloading" of geometry, as if it doesn't take its time to load, it just gives up and closes.

Some final notes:

  • It's a high end PC with i7-5960X@3.0GHz, 64GB ram, 2xSSD, GTX1080

  • latest Blender version, does not happen with any other project (much less complex)

  • Updated Windows 10, updated drivers

  • It doesn't look like a corrupted blend file, I've had that before, doesn't look the same.

  • I can't share the file.

  • The file is 1.1GB

I hope I'm providing useful and accurate information, this started happening a couple of weeks ago, and it's hard to keep track of everything that happens, let me know what other information I may provide.

If possible, I'll try and test it on my home computer and see if I have different results.

Thank you for your time and patience, appreciate your help.

$\endgroup$
  • $\begingroup$ Managed to clean the "utility" layers, keeping only 3 and 4, ~1.5M tris across all layers now, too soon to tell but seems to help, opening, loading, local view, etc. $\endgroup$ – Valthrudnir May 3 '17 at 11:41
  • $\begingroup$ These are all results of biting more than you can chew, your scene is too complex for your hardware/blender. I'd say you should be setting up a blend file for the final model you want to be exporting alone and nothing more. Everything else that is used as a helper should at best be referenced from an external file as link, and at worse removed completely. $\endgroup$ – Duarte Farrajota Ramos May 3 '17 at 12:47
  • $\begingroup$ I appreciate your feedback and I'll investigate links, but I'm not convinced that it could be "hardware" by itself. A complex scene can be many things, and I've worked with scenes up to 11m tris, maybe not so many objects but another type of "very complex". I've since deleted all utility layers, keeping only my final models, and it happened again leaving local view to model something in detail, it has 1.6m tris right now, at this point, if it's hardware, then I know nothing. $\endgroup$ – Valthrudnir May 3 '17 at 14:11
  • $\begingroup$ May not be specifically hardware related, but Blender's limits themselves. Having 1.6m tris in one object is not the same as having it in several thousand objects, object count has a heavy influence in scene performance. Try to see if you can isolate the crash to one specific object by eliminating one by one. If you can do report a bug to the tracker. $\endgroup$ – Duarte Farrajota Ramos May 3 '17 at 18:21
  • $\begingroup$ Now that makes sense, the scene is fragmented in many objects (not thousands though), and several objects with messy geometry, but the original file was exactly like that. It's not realistic to look for a faulty object one by one, but I'll keep an open eye and review the geometry in my project. In the meantime, debug mode only gives me the message "error exception_access_violation", I tried clean install, and previous options (i.e. not "Load UI") and minor things, I'm not replacing DDL's manually. Eventually I'll make a system recovery and check if anything changed. $\endgroup$ – Valthrudnir May 4 '17 at 8:34
0
$\begingroup$

I want to confirm that it was one object in the whole file that caused all this trouble, once I managed to locate it and delete it, the problem doesn't happen anymore.

@Duarte Farrajota Ramos, I tried to get the object to another file, but it will crash when I "paste" it on a new document and I can't append the file, I can't even go to edit mode, but I ended up deleting everything else and keep only that object.

Layer 1 has the original object, layer 2 has it in the "new" location and rotation and layer 3 has the faulty object, which was edited somehow. This geometry is "junk" and it's supposed to be deleted regardless, I don't think I'd bother to edit this geometry, since the original file had a lot of useless geometry for the purposes of real time rendering.

Thank you very much, I narrowed it down due to your input.

Cheers

-John

enter image description here

Blend File Download

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.