29
$\begingroup$

I'm trying to unwrap a cube (I know, super complicated). I've got the seams marked, the UV editor open in a 2nd window, and all the geo highlighted. When I tell the cube to unwrap nothing happens. That's pretty much the long and short of the problem. Now I've been working off this one file for a couple weeks now, saving it off the original file and continuously cloning geometry. It's entirely possible I did something, pressed a button, something.

Any thoughts.

$\endgroup$
  • 4
    $\begingroup$ To unwrap uv's you mark any seams you want, select the faces you want to unwrap, press U and select one of the unwrap options while in edit mode. Only selected faces (or those surrounded by selected verts/edges) will be unwrapped. Only selected faces will show up in the uv editor. My guess is you aren't selecting anything. $\endgroup$ – sambler Mar 20 '14 at 12:37
  • $\begingroup$ No everything is selected and I'm in edit mode. The seamed edges are red and the selected faces are bright orange. That part isnt the problem. Selecting an unwrap option, and I've tried all of them, produce no visible result in the UV Editor. In a bit here I'll post the file in question and then I'll start pulling my hair out as someone makes it all happen in one go I'm sure... $\endgroup$ – Stinkhorse Mar 20 '14 at 18:50
  • $\begingroup$ Here's a link to the blend itself: [link]dl.dropboxusercontent.com/u/8750289/cube%20unwrap%20issue.blend $\endgroup$ – Stinkhorse Mar 20 '14 at 20:12
  • $\begingroup$ I just created a new blend file and built the exact same object. The unwrap worked just fine. Something is clearly wrong with the file I linked. $\endgroup$ – Stinkhorse Mar 21 '14 at 0:40
  • 3
    $\begingroup$ You can pull your hair out now... ;-) you don't see the uv's as you are displaying the render result in the image editor, change it to an image or click the X to hide the render result and you will see them. $\endgroup$ – sambler Mar 21 '14 at 0:48
42
$\begingroup$

To unwrap UV's, you mark any seams you want, select the faces you want to unwrap, press U and select one of the unwrap options while in edit mode.

Only selected faces (or those surrounded by selected vertices/edges) will be unwrapped. Only selected faces will show up in the UV editor.

Also UV's aren't displayed in the UV/image editor if the Render Result is displayed in the UV/Image Editor. You need to select an image or click the X to close the render result to see UV's.

$\endgroup$
  • 3
    $\begingroup$ Huge thanks man. I'm still stumbling through the program pretty badly at the moment and I would be lost without you and others like you. $\endgroup$ – Stinkhorse Mar 21 '14 at 1:28
  • 1
    $\begingroup$ Lifesaver. I forgot that you need to specify which faces to unwrap! I wonder if it would be reasonable for blender to unwrap the whole object by default, if no faces are selected. $\endgroup$ – sudo make install Oct 5 '15 at 20:50
  • $\begingroup$ Ditto - This has been great news. I didn't know what the 'X' was for, so didn't want to close something I didn't intend to. Thanks, @sambler! $\endgroup$ – moosefetcher Oct 14 '16 at 14:20
  • 1
    $\begingroup$ This is terrible, failing without showing an error $\endgroup$ – Dr Deo Dec 5 '16 at 23:05
  • $\begingroup$ AFAIK, it doesn't fail, it works just fine--it just doesn't show you what it did. (: $\endgroup$ – SilverWolf Oct 22 '17 at 19:06

protected by iKlsR Oct 4 '15 at 13:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.