2
$\begingroup$

This question already has an answer here:

I'm new to Blender and I finished one scene. Everything is good when I look at the scene in the object mode or rendered preview, but when I actually render the scene, my doughnuts disappear and the icing starts looking very sharp and edgy. Please, look at the attached images. Could someone tell me what I'm doing wrong? enter image description here

$\endgroup$

marked as duplicate by iKlsR Oct 31 '18 at 6:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

5
$\begingroup$

My assumption is that it is hidden from the render. Go to the outliner and make sure that both the eye and camera aren't grayed out.

enter image description here

Otherwise make sure that all of the following optios are checked (make sure object is selected). enter image description here

Edit

Icing:

In the modifier tab make sure render of the subdivision-surface is same as view.:

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Another possibility can be scene render layers. The sharp edges can be due to the two settings in the SS modifier: one for preview and one for rendering $\endgroup$ – lemon Apr 30 '17 at 10:46
  • 2
    $\begingroup$ I guess, but I watched the series (Blender Guru) which this scene is based on, and it doesn't touch render layers. I doubt a beginner would use more intermediate tools such as render layers. But yes it could be the render layers. $\endgroup$ – Nils Eisen Apr 30 '17 at 10:52
  • $\begingroup$ Yes, so many possibilities, That's why I've been asking for the exact problematic file, especiallly for a what-is-wrong-with-my-scene question like this. $\endgroup$ – Leon Cheung Apr 30 '17 at 13:13
  • $\begingroup$ A file would be helpful because of what you said $\endgroup$ – Nils Eisen Apr 30 '17 at 13:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.