2
$\begingroup$

This may sound stupid idk but my message sensor can't seem to read the message sent by one of my actuators? I have a plane which plays its animation when a key is pressed and has an actuator which sends a message to my human with the subject "Earthquake". My human has a message sensor with the same subject. It is supposed to match right? Or am I doing it wrong? Replies will be very much appreciated thank you!

$\endgroup$
  • $\begingroup$ Yes the subject in the message actuator and sensor need to match, they are case sensitive and exact, an extra space will break it. Is the actuator sending to the right object? You can leave the object empty in the message actuator to have it sent to every object. Are you sure that it isn't receiving or is the actuator attached to the message sensor not working? $\endgroup$ – sambler Mar 19 '14 at 7:25
3
$\begingroup$

In the first screen shoot, I have a Keyboard sensor, on the object ground plane, send a message to all objects (the empty To field) with a Subject of somthing (with the misspelling).

Drag the images to a new tab to enlarge them. send message

In the second screen shoot, Now on the object human. There is a message sensor listening for a message with the subject somthing. When it receives a message (from any object) with the subject somthing the connected action actuator plays the animation. receive message

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.