1
$\begingroup$

Just installed blender 2.78 on windows 8.1 under parallels. When I start the game engine, the cursor disappears when it enters the blender window. Crtl-alt to release the cursor doesn't help. changing the settings to optimize or not for games doesn't help.

Different problem on blender install directly on the mac (10.12.5). Here, when I start the game engine the blender window just flickers rapidly and becomes entirely unusable.

In both cases everything is fine until the game engine starts.

Any guesses?

$\endgroup$
  • $\begingroup$ This is expected behavior, cursor is hidden by default unless coded otherwise. $\endgroup$ – Duarte Farrajota Ramos Apr 26 '17 at 0:48
0
$\begingroup$
  1. To see the mouse cursor when bge is running active Mouse cursor checkbox in render tab of property panel.

property panel

  1. Or use a script to show the mouse cursor.

    script

You can use logic or render to show the mouse cursor while BGE is running.

  1. Using bge.logic.mouse

     from bge import logic
     logic.mouse.visible = True # 1 or True are acepted, to disable 0 or Flase
    
  2. Using bge.render.showMouse()

    from bge import render
    render.showMouse(1) # 1 or True are acepted, to disable 0 or False
    

NOTE: When BGE is running you are unable to make change to configurations, property, objects, scripts, etc.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.