0
$\begingroup$

I found a situation that I don't understand. It seems that the automatic weight painting does not work with the girl that I have rigged using rigify. I don't understand the reasons of this behaviour,because :

1) I'm trying to deform the parts of the mesh that are attached with the DEF bones

2) I'm repeating the steps that I did previously with the boy and it worked

3) I split the mesh into several pieces and I have attached each piece to the rig called "rig.girl" under the armature modifier tab

Let's take as example the bone called "DEF-forearm.L.001". I would like that it deforms the "braccio_sx_girl" aka arm_left_girl. What I do to achieve this output ?

a) I select the bone "DEF_forearm.L.001" ;

b) I press SHIFT and then I select "braccio_sx_girl" ;

c) I change from object mode to weight paint mode ;

d) I do weights / assign automatic from bones ;

but the mesh is not deformed....

NB : I repeated again the steps from "a" to "d" with the boy and it worked.

This is the blender file. ​

$\endgroup$
1
$\begingroup$

My friend, you have "Face selection masking for painting" enabled. Disable it by clicking on the icon in the red circle on the image attached, and everything will back to normal.enter image description here

$\endgroup$
  • $\begingroup$ I'm trying to fix this problem since 2 days. You come back and boom. You fixed it. You are the man. How did I not notice it ? I don't know. $\endgroup$ – Marietto Apr 26 '17 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.