0
$\begingroup$

I was trying to texture a car, but then I realized that some faces dont have their UV map applied. I cant really explain what's happening. It looks like that there are two kinds of groups; when I select the entire model and apply a UV Map to it only one of the groups of faces actually uses it. The other stays with their current UV Map.

The car model: https://docs.google.com/file/d/0Bz5XxZPILhgEc3h2NVk4QnZPalU/edit

$\endgroup$
3
  • $\begingroup$ The file link requires access permission, please check it again. And, it seems you have two UV sets for different face groups. $\endgroup$ Mar 17, 2014 at 15:24
  • $\begingroup$ Ah, fixed. How would I change these UV sets? $\endgroup$
    – Gyt Dau
    Mar 17, 2014 at 16:10
  • $\begingroup$ I assume when you said "apply a UV Map" you were actually talking about "apply a texture", right? If so, I don't see any faces weird here, so far so good. And there is only one UV set here. Hmm, you need to upload file that can expose the weird things. :) $\endgroup$ Mar 17, 2014 at 17:36

1 Answer 1

1
$\begingroup$

There is a mode in the UV Editor called Sync Selection. When Sync Selection is enabled; selecting the entire model in the 3D Viewport will select everything in the UV Editor; however! when Sync Selection is disabled this will not happen.

To select everything when Sync is disabled you must first select everything in the 3D Viewport and then again in the UV Editor. This mode allows you to work on UV coords independently but will often cause the problem you are describing.

Make sure that everything is selected in the UV Editor and then reapply the texture.
You might want to keep that little button activated all the time until you get used to it.enter image description here

$\endgroup$
6
  • $\begingroup$ I didn't really get what that button did, as I imagine I had that on already, but I followed your instructions, resaved, reimported to Unity, and now everything's fixed. Thanks! $\endgroup$
    – Gyt Dau
    Mar 17, 2014 at 17:57
  • $\begingroup$ Your welcome, basically the way you had it set will allow you to move vertices that are on the UV island boundaries without moving the vertices that also correspond to other islands. Also, with this setting, you can use the 'L' key to select whatever island the mouse cursor is hovering over. With Sync Selection enabled you cannot do this. $\endgroup$ Mar 17, 2014 at 18:05
  • $\begingroup$ Oh, nevermind, now it seems that it reversed itself. It's still broken, even with the tool enabled. Here's what I mean: i.imgur.com/CyIvYc8.png $\endgroup$
    – Gyt Dau
    Mar 17, 2014 at 18:10
  • $\begingroup$ Could somebody here try to do it? Maybe I'm doing something wrong... $\endgroup$
    – Gyt Dau
    Mar 17, 2014 at 18:22
  • 1
    $\begingroup$ You do have 2 materials assigned to the model and it is 'Material' that is assigned to the missing areas. 'Material.001' is assigned to the parts that are working. There is a texture activated for 'Material' but no texture is actually assigned like what you have for 'Material.001'. You can either assign all the faces to 'Material.001' or add the texture for 'Material' It might also help to name things yourself so this confusing conversation does not happen. $\endgroup$ Mar 17, 2014 at 18:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .