2
$\begingroup$

I have a model that I sculpted and retopologised in another application, and then imported the retopologised mesh into Blender with a normal map.

The mesh is around 9200 verts, and I have smooth shading turned on.

I am getting an odd shading artifact in the form of jagged edges: enter image description here

While the surface is not perfect, it seems more than smooth enough that this artifact should not be happening.

The object has a normal map applied (baked from the high quality sculpt), but I can turn that off an get the same thing:

enter image description here

Here is a shot of the wireframe:

enter image description here

Is this abnormal like I think it is? What might be causing it? I have checked the mesh for everything I can think of.

EDIT: I have made the file available here (20M, sorry):

$\endgroup$
  • $\begingroup$ "I have checked the mesh for everything I can think of." Does that include double faces/vertices and/or inverted normals? That's what it looks like to me. $\endgroup$ – SvB Apr 20 '17 at 19:43
  • $\begingroup$ Remove doubles, make normals consistent and non-manifold geometry. Check, check and check. $\endgroup$ – Lewis Apr 20 '17 at 19:46
  • $\begingroup$ Can you share the model? $\endgroup$ – Rich Sedman Apr 20 '17 at 22:26
  • $\begingroup$ Any edges marked sharp or crease or anything? That can be hidden or obscured by UV seams, check the N panel for vis options. $\endgroup$ – StarWeaver Apr 20 '17 at 22:32
  • $\begingroup$ Does that show up if rotating model and looking at it from another view points? It could be terminator problem although I barely think it is. Try also enabling Smooth shading in Edit mode with all faces selected; maybe those still use Flat shading. $\endgroup$ – Mr Zak Apr 20 '17 at 23:12
1
$\begingroup$

The mesh is fine. The primary cause of the geometric shadow is the texture co-ordinates you have given the HDR environment. The simple HDR setup here...

enter image description here

...results in a smooth shadow.

enter image description here

As reference: Trouble Viewing Whole HDR Image as cycles world

The PBR node you have added obvious effects the edges...

enter image description here

$\endgroup$
  • $\begingroup$ I'd like to add that this Problem is celled the "Terminator Error/Problem" and can also happen in other render engines. This error isn't just caused by HDRIs as it can also happen in other situations, often when the model has a subsurface Modifier on it. Usually the best solution is just applying the Subsurface Modifier. $\endgroup$ – Nils Eisen Apr 21 '17 at 9:37
  • $\begingroup$ Thanks! I think you are right, in that the HDRI setup (which is just the Gaffer HDRI manager setup) was severely highlighting the problem, but I also agree with @NilsEisen in that this problem seems to be more than just that. I can see the bad shading with different HDRIs and even no HDRI at all. I have enough understanding of the issue to go one now and can experiment for better results. $\endgroup$ – Lewis Apr 21 '17 at 12:01
  • $\begingroup$ I believe Campbell Barton (One of the main Blender Contributors) was saying that this is a hard issue to tackle but is in the process of being fixed or at least reduced. $\endgroup$ – Nils Eisen Apr 21 '17 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.