6
$\begingroup$

I created a model in another program, and imported it to Blender to map the UVs. Parts of the model are symmetrically flipped mesh planes. I noticed in Blender that the mirrored objects display as darker, and on further checking, I find that the face and vertex normals are in one direction and the "vertex-per-face" normals are opposite.

I've tried the Recalculate Outside and Flip Normals commands, but that just inverts them without unifying the direction. How can I flip JUST the "vertex-per-face" to get them all in the same direction, as they are in the original un-mirrored object that was copied?

Weird Normals

$\endgroup$
  • 1
    $\begingroup$ Most likely that's because of custom split normals imported with the object from the 3rd party software; most likely you'll need to remove it in the Object Data tab > Geometry Data rollout. You'll reconstruct shading in Blender if you need it. $\endgroup$ – Mr Zak Apr 19 '17 at 23:10
1
$\begingroup$

Those purple lines are normals generated by Auto Smooth. It has checkbox under the Object Data tab > Normals rollout. I would recomend you just turn that feature off. If you want some complex shading, you should generaly use Sharp Edges with an Edge Split Modifier.

enter image description here

$\endgroup$
  • $\begingroup$ There always will be normal vectors generated when adjusting edge split because of splitting, no matter which way to use - Autosmooth or Edge Split. As of several recent Blender versions Autosmooth has support of sharp edges, so it's essentially the same as modifier (the only difference is normals exporting) $\endgroup$ – Mr Zak Apr 19 '17 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.