5
$\begingroup$

I accidentally pressed some unknown key combination, and now I can't use Undo nor Redo in Blender

$\endgroup$
5
  • 1
    $\begingroup$ Basically, SHIFT + ALT toggles between being able to undo/redo and... NOT being able to undo/redo. That's all. $\endgroup$
    – noClue
    Apr 19, 2017 at 14:26
  • $\begingroup$ Can you clarify what you mean? Pressing Shift + Alt when? As far as I am aware there is no way to disable undo/redo. $\endgroup$ Apr 19, 2017 at 14:54
  • $\begingroup$ If you are using English Software (Blender) but an Azerty keyboard, accidentally hitting Shift + Alt keys toggles the keyboard to the Querty setup. This effectively "disables" the the Undo/Redo shortcuts. But of course they still work but now you need to use Ctrl + W to Undo instead of the usuall Crtl + Z. Or use Shft + Alt to toggle back to your usuall keyboard setup. $\endgroup$ Apr 19, 2017 at 17:09
  • $\begingroup$ @3fingeredfrog That is indeed curious and useful information, unfortunately the way the question and answer are worded it is impossible to understand what you explained. Could you please edit them so they read more like your comment. $\endgroup$ Apr 19, 2017 at 22:55
  • $\begingroup$ @Duarte Thanks for making my comment a little more understandable :) $\endgroup$ Apr 20, 2017 at 19:54

4 Answers 4

9
$\begingroup$

If you are using English Software (Blender) under Windows based Operating Systems but with an AZERTY keyboard, accidentally hitting Shift+Alt keys toggles keyboard layouts, as explained here.

This apparently "disables" the Undo/Redo operators, when in fact what happens is it changes the keyboard shortcuts

Ofcourse they still work, but now you need to use Ctrl+W to Undo instead of the usuall Ctrl+Z, or use Shift+Alt to toggle back to your usual keyboard layout.

You can also disable the shortcut in the Regional Options of the control panel if you follow the steps described here

Credit goes to 3fingeredfrog for the explanation

$\endgroup$
1
$\begingroup$

I had the same problem, but in my case wasn't by an key combination.

If other answers didn't solve problem go to the Blender Users Preferences > Edit > Activate Global Undo (optionally add more steps if you want).

$\endgroup$
0
$\begingroup$

⌃ Ctrl + ⌥ Alt + U > Preference > System > Memory and limits > Global undo

$\endgroup$
0
$\begingroup$

For Mac, it is solved by hitting ⇧ Shift + Option

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.