2
$\begingroup$

I used Blender for a while then I stopped using it a few months back and yesterday when I tried running it, it crashed and gave me this error:

AL lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead
Error: EXCEPTION_ACCESS_VIOLATION

These is what I tried:
-Uninstalling then installing the newest version
-Uninstalling again then installing an older version
-Deleted every registry file and folder related to Blender
-Reinstalled 50 times
-Restarted my PC 10 times
-Installed Python 10 times (before and after Blender)

Non of this works and there I can't find the explanation why, I searched online but can't find the same case happening to someone else.

EDIT: All drivers are up-to-date!

$\endgroup$
5
  • $\begingroup$ have you seen this blender.stackexchange.com/questions/77857/…? $\endgroup$ – m.ardito Apr 19 '17 at 9:33
  • 2
    $\begingroup$ @m.ardito it is not the top line that is the problem but the "Error: EXCEPTION_ACCESS_VIOLATION" $\endgroup$ – David Apr 19 '17 at 13:32
  • 2
    $\begingroup$ Try the zip version of blender. just unzip and run, no install or external python needed. $\endgroup$ – David Apr 19 '17 at 13:33
  • $\begingroup$ Okay I'll try the zip thing $\endgroup$ – Bojaniko Apr 19 '17 at 18:43
  • $\begingroup$ Didn't work ... $\endgroup$ – Bojaniko Apr 19 '17 at 18:49
1
$\begingroup$

I finally figured it out, just downloaded a file called "opengl32.dll" and put it in the Blender directory

$\endgroup$
5
  • 2
    $\begingroup$ That likely indicates that there is something messed up with your graphics. See the opengl32.dll makes blender do all graphics processing (drawing blender' ui, the 3D view, and rendering) on the cpu. What graphics card do you have? $\endgroup$ – David Apr 20 '17 at 14:28
  • $\begingroup$ I have a GTX 750 Ti but it's the 1GB version $\endgroup$ – Bojaniko Apr 20 '17 at 14:29
  • 1
    $\begingroup$ Blender is lagging a lot now $\endgroup$ – Bojaniko Apr 20 '17 at 14:31
  • $\begingroup$ See if blender.stackexchange.com/q/61749/2217 helps. $\endgroup$ – David Apr 20 '17 at 14:32
  • $\begingroup$ My GPU driver is updated $\endgroup$ – Bojaniko Apr 20 '17 at 15:09
0
$\begingroup$

Downgrading blender was the only thing which worked in my case.

(Updating blender and updating graphics card, and look if the blender install is clean like described here didn't work for me)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.