0
$\begingroup$

According to the Blender wiki here, as of Blender 2.78c (or around May 20, 2016), procedural cycles materials should display in the Blender viewport in "Material" mode. Unfortunately, this is not working for me.

Musgrave, Voronoi, Noise, Magic, and Brick textures all refuse to display in the viewport. Checker is the only one that works, and it doesn't shade properly.

Is there some option to enable GLSL for these? Could it be a graphics card issue?

I know there are several questions on here about this, but as of May 20 last year, this feature should be implemented. I am using the latest build of blender off GraphicAll, and am on Windows 7 64 bit.

Here is a screenshot of the result in material mode and my node setup:

Material mode

$\endgroup$
  • $\begingroup$ Have you tried a build from blender.org? $\endgroup$ – MasterHolbytla Apr 18 '17 at 16:31
  • $\begingroup$ What version of Blender are you using? What graphics card do you have? Are your drivers up to date? What happens when you change viewport to Material mode, could you post some screenshots of what it shows, and some images of your material node setup? $\endgroup$ – Duarte Farrajota Ramos Apr 18 '17 at 16:31
  • $\begingroup$ @DuarteFarrajotaRamos As I mentioned, I am using the latest build of Blender 2.78 off GraphicAll. My graphics card is a Nvidia Quadro 2000, and the drivers are updated. When changing to Material mode, the object gets bright, almost white, but has no texture. I'll append a screenshot to my original post. $\endgroup$ – CGEffex Apr 18 '17 at 16:34
  • $\begingroup$ @MasterHolbytla I have not yet, but I had this same issue with an older build of 2.78c. $\endgroup$ – CGEffex Apr 18 '17 at 16:37
  • 1
    $\begingroup$ Working well on my end, might be a graphics issue. Try one of the official builds from Blender.org or buildbot. Also make sure your object's Maximum Draw Type is set to Textured and nothing else in the Properties Window $\endgroup$ – Duarte Farrajota Ramos Apr 18 '17 at 16:46
0
$\begingroup$

I fix it by enable node wrangler add ons. I use internal VGA.enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.