0
$\begingroup$

I'm using Ubuntu 32bit 16.something. Blender isn't showing shadows in the viewport or bge. I can render shadows but I need to use them for the game engine. I'm on blender game, textured view, glsl, shadows/shaders enabled in both render and light data panels. shadow error screenshot

$\endgroup$
  • $\begingroup$ Texture shading mode as the name implies shows textures, you should be in Material view. Also activate the shadows for your Sun lamp $\endgroup$ – Duarte Farrajota Ramos Apr 18 '17 at 0:16
  • $\begingroup$ Had to reinstall ubuntu cause an update caused my keyboard to malfunction. No that doesn't work for me here. Is there any sort of error debugging method I could use to see what the issue is? $\endgroup$ – Jacub Apr 18 '17 at 1:13
1
$\begingroup$

You need to activate shadows in lamp property.

enter image description here

If that not the problem, change the energy in the second lamp.

enter image description here

Reduce energy.

enter image description here

$\endgroup$
  • $\begingroup$ Nope, I get the opposite of a bright white scene, all the objects turn black. Again I'm using Ubuntu, I didn't have this problem on Windows. I've tried every selectable option that I know of to enable shadows for the viewport but nothing works. $\endgroup$ – Jacub Apr 19 '17 at 0:37
  • $\begingroup$ Then the problem may be related to the GPU and OpenGL driver, not blender. What brand is your GPU ?, Are you opening blender from the console? So you can see if it gives you some error. Do you know if you have installed the drivers of your GPU and OpenGL? $\endgroup$ – Strapicarus Apr 19 '17 at 1:49
  • $\begingroup$ This is what Ubuntu's terminal tells me. *-display description: VGA compatible controller product: Core Processor Integrated Graphics Controller vendor: Intel Corporation physical id: 2 version: 02 width: 64 bits clock: 33MHz capabilities: msi pm vga_controller bus_master cap_list rom configuration: driver=i915 latency=0 resources: irq:29 memory:d0000000-d03fffff memory:c0000000-cfffffff ioport:5050(size=8) memory:c0000-dffff $\endgroup$ – Jacub Apr 19 '17 at 2:04
  • $\begingroup$ I found this bug report not related to blender, but related to your hardware, affecting libre office Calc using OpenGL. >On enabling OpenGL, LO crashes at the splash screen. On disabling, it works fine, but the active cell is not marked in any way. So maybe the problem is retaled to your hardware and OpenGL on ubuntu 16 and affect the way Blender viewport render shadows. Sorry to say but maybe you need to go back Windows to use Blender until this bug get fixed. Or get more help or info in ubuntu and OpenGL forums. $\endgroup$ – Strapicarus Apr 19 '17 at 3:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.