1
$\begingroup$

I'm finding the Blender crashes when opening an old VSE only .blend file (default cube, light and camera in 3D view) that was saved when I didn't have Filmic installed. This isn't a problem with geometry files, only ones with strips and modifiers in the VSE. This now means that all my old VSE project files cannot be opened.

An excerpt from the console when in debug mode:

Version 268 sub 0 date unknown hash
.
.
.
Color management: display "sRGB" used by scene not found, setting to default ("sRGB / BT.709").
Color management: scene view "Default" not found, setting default "sRGB EOTF".
Color management: sequencer colorspace "sRGB" not found, will use default instead.
.
.
.
wm_window_make_drawable: set drawable 1
Error: EXCEPTION_ACCESS_VIOLATION

A quick test seems to show that the reverse might also be true, that new VSE only files cannot be opened in a copy of Blender without Filmic installed.

I have updated the start file to use Filmic valid defaults on load and the three warning messages disappear but the Access Violation still happens.

$\endgroup$
  • $\begingroup$ I'll advert Troy about this question, but yes, even if I've never had any compatibility problem with 3D scene, it can, from what I've read. In all the cases you can go back to default color management to open the old files. I know it's not really an option to work without when you've tried it ^^. $\endgroup$ – Mareck Apr 17 '17 at 12:10
1
$\begingroup$

I see you are using v2.68, try updating to the newest release.

https://github.com/sobotka/filmic-blender/issues/24

$\endgroup$
  • $\begingroup$ I'm using Blender version 2.78c. I'm not sure what that number in the debug output refers to but it doesn't match the program version. The link refers to a trunk fix in December last year so I'm assuming that fix is present in the official release 2.78c. I'm also using the latest github version of filmic in case there was a fix there. $\endgroup$ – PaulMc Apr 17 '17 at 21:35
  • $\begingroup$ Update: My apologies it appears I posted the wrong log file - this was the older version of Blender which exhibits the same bug the other way around. The newer log file contains the identical error but includes the following line near the top: Version 278 sub 0 date 2017-02-24 14:33 hash e92f235283 $\endgroup$ – PaulMc Apr 17 '17 at 21:41
  • 2
    $\begingroup$ Should be fixed in trunk. $\endgroup$ – troy_s Apr 18 '17 at 3:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.