1
$\begingroup$

I'm working on a lamp scene following a tutorial (kind of like the Pixar intro). However, I've noticed a problem with the lighting. I have a large weak light (plane) that lights the scene, but when I have it active the light from the lamp object doesn't show up on the background plane hardly at all, unless I really crank up the samples (I've gone up to 4000 and it still looks not great).

Pictures for reference (rendered with 100 samples): enter image description here Here the lamp is the only light source.

enter image description here Here the secondary light source is also rendered. As you can see, this makes the light from the lamp really grainy... hardly even visible.

I understand that it's harder to compute for multiple light sources, but in the past I haven't had these problems with Cycles. Then again I've never had to use such a harsh light. Is there any way I can fix this?

Thanks!

$\endgroup$
  • $\begingroup$ You can download the file here if you want a closer look at the settings. $\endgroup$ – Spencer Smith Apr 16 '17 at 2:44
2
$\begingroup$

Try disabling multiple importance sampling in the material settings of the large emission plane.

I'm not sure exactly how multiple importance sampling decides what to do, but I suspect its deeming the giant emission plane much more likely to contribute to those samples than the tiny mesh light inside the lamp mesh. As a result, it concentrates its efforts on the big mesh lamp, at the expense of the little mesh lamp. Disabling MIS on the big lamp takes it out of the importance sampling equation entirely, so special treatment is concentrated on the small lamp again.

You can also use a spot lamp in place of the tiny mesh lamp. In general, the lamp primitives are faster and less noisy than mesh lights.

enter image description here

$\endgroup$
  • $\begingroup$ Thanks, I tried both of those and it renders much better! $\endgroup$ – Spencer Smith Apr 16 '17 at 19:47
1
$\begingroup$

A workaround I have found in the past is to position a point lamp near the bulb, which might consider cheating but it gives a good result.

Here is the .blend where I changed the clamp values and made the point lamp a child to the armature.

Lamp

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.