1
$\begingroup$

I am trying to use the Cutaway shader by iReboot (aka Dylan Whiteman) as found on his page here. However, the results are not exactly as expected. The model shown in the attached screenshot is made of planar geometry with solidify modifier, and it uses particle systems to instance other assets. Both the planar objects (particle generators) and the particle objects have the cutaway shader material applied. But the render preview shows parts of the object that are supposed to be hidden away in black. Would you know what might be causing this? Any suggestions for how I can fix the issue?

Screenshots of rendered, solid, and wireframe views of the model

(Also, I do not want to use boolean modifiers to achieve a sectional view because they do not work well with large complex geometries that are required in this case because of the need to use particle systems.)

$\endgroup$
  • 1
    $\begingroup$ Try increasing transparency bounces in render settings $\endgroup$ – Duarte Farrajota Ramos Apr 16 '17 at 2:38
2
$\begingroup$

The fix Duarte Farrajota Ramos suggested worked. Attaching screenshot of settings for reference. It was not an issue with the Cutaway shader add-on, but a matter of increasing the number of transparency bounces under the Light Paths subhead of Render settings.

Screenshot of solution

Thank you!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.