3
$\begingroup$

Let's say, I want to populate a parking lot with cars. Coming from Modo, I'd use replicators: -create an array of polygons, one for each parking space -create a group of cars -add a replicator item, that would place one car on every polygon and use the polygon's rotation to place the replica -I could do a random rotation in 180 degree increments, to get some randomness -I could also rotate polygons manually for more control -A percentage slider and seed value allowed me to control how full the parking lot was

Is there a way to do something similar in blender? I've come quite close with the hair system, but I can't figure out how to precisely control the Z rotation of individual hairs

Any pointers will be much appreciated. Thanks in advance

$\endgroup$
  • 2
    $\begingroup$ You might have better luck with dupligroups if you want manual control. If you use duplifaces you can control orientation, and iirc there is a tool to randomize face orientation $\endgroup$ – gandalf3 Apr 14 '17 at 20:03
  • $\begingroup$ cool! this works nicely, although I haven't been able to figure out the randomization part just yet. Is there also a way to do this controlled duplication with a group or a hierarchy, so that I don't have to merge the whole model before duplicating it? $\endgroup$ – ivan Apr 15 '17 at 9:45
  • $\begingroup$ I came close to getting something like that working with groups and mask modifiers, but I realized particles should allow this after all. $\endgroup$ – gandalf3 Apr 15 '17 at 19:56
2
$\begingroup$

Blender's particle system is.. weird. It's a more little old and probably could do with a refactor. Among other things, the axis are wrong.

However, that doesn't mean it can't be made to work:

  1. Switch to emission particles
  2. Enable rotation

    enter image description here

  3. Rotate your emitter polygons so that their surface normals are aligned with the +Y axis of the instance:

    enter image description here

$\endgroup$
  • $\begingroup$ ah, this is cool! thanks! It's quite a shame the X axis gets ignored, but this does make my problem seem at least a bit closer to getting solved. Also... how do you update your particle sim after you exit the edit mode of the source surface? my particles didn't update until I changed their number... $\endgroup$ – ivan Apr 26 '17 at 14:05
  • $\begingroup$ @ivan Hm, I didn't do anything special.. Are you using blender 2.78? I've uploaded the .blend for you to test. $\endgroup$ – gandalf3 Apr 27 '17 at 0:17
  • $\begingroup$ thanks, works as expected in your file, I'll have to dissect my old file... if I can find it, to find the culprit. $\endgroup$ – ivan Apr 27 '17 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.