2
$\begingroup$

I have a blend file where smooth surfaces are somehow rendered in a terrible way (full of black spots, rough edges, bad reflection.. the works).

  • If I export the object (fbx) and import into a new .blend file, everything is fine
  • In non-render modes (Solid / Material mode) everything looks butter smooth

So the issue seems not to be with the object, but rather with the render / other blender settings - but I can not fine anything wrong!

Any help is greatly appreciated :).

You can find the file <>.

Warner

render

$\endgroup$
  • $\begingroup$ Downloaded the file, but everything seems to render fine. I am not getting the black artifacts in your screenshot. $\endgroup$ – Lewis Apr 14 '17 at 10:00
  • $\begingroup$ Trying a bit further, I'm only getting them when opening the file and setting the viewport to 'rendered'. It seems with F12 (camera render) everything goes fine. Also that way you don't have any issue? $\endgroup$ – Warner Apr 14 '17 at 10:30
  • $\begingroup$ This above is exactly what happens to me... how to get rid? I don't know, atm. $\endgroup$ – m.ardito Apr 14 '17 at 10:39
  • $\begingroup$ The object is relatively too small, imho. Try (just a test) to scale it up 20x and see what happens in viewport... ;) $\endgroup$ – m.ardito Apr 14 '17 at 10:43
  • $\begingroup$ Scaling doesn't seem to have any effect.. However, "re-setting" the viewport with ctrl-0 (set view on selected object) seems to somehow resolve the issue. Not sure why - perhaps a bug? $\endgroup$ – Warner Apr 14 '17 at 10:53
1
$\begingroup$

Change the end clip view parameter (N Panel) to something smaller.
before :bad clip
after :good clip

$\endgroup$
  • $\begingroup$ Thanks Bithur! Though, it seems your solution has the same effect as the "re-set" of the viewport with ctrl-0.. the 50km value doesn't seem to be the underlying symptom. $\endgroup$ – Warner Apr 14 '17 at 12:06
  • $\begingroup$ Your problem only occurs in ortho view, not in perspective. Ctrl+0 uses the selected object as camera (no reset), changing the view to perspective and making the problem disapear. If you get out of camera view (Numpad 0) and go back in ortho view (Numpad 5) the problem will come back unless you change the end clip. $\endgroup$ – Bithur Apr 14 '17 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.