I am new to blender and 3d design in general. I have a model which has smooth curved surface but the edges are not round. So I like to subdivide the faces to get a smooth shape.

When I select the faces and use Subdivide smooth I lose the smooth surface. I have tried any options I could see such as smoothing the vertexes, smoothing the faces and etc under the Shading tools, recalculating normals and almost all the uv mapping options with no luck.

What is interesting to me is that if I create a new Ico Sphere and make the faces smooth under shading and then select some faces and subdivide in the same fashion, the surface remains nice and smooth.

I also read about using subdivision surface modifier, but that one seems to only do whole object and not just selected faces in my case.

Any help would be much appreciated. Thanks!

After subdivide

  • $\begingroup$ Upload your file on blend-exchange.giantcowfilms.com to be able to help you $\endgroup$ – Tak Apr 14 '17 at 0:28
  • 1
    $\begingroup$ Your triangle-heavy topology might be part of the problem, triangulated meshes don't play well with many workflows. $\endgroup$ – Duarte Farrajota Ramos Apr 14 '17 at 0:59
  • $\begingroup$ Actually it wasn't triangulated at first. I switched the model to triangulated to see if that makes a difference and it is acting exactly the same. $\endgroup$ – Chris Apr 14 '17 at 1:35

In the edit mode with the vertex selected go to vertex panel at right hand and uncheck auto smooth

enter image description here

With the vertex selected go to tools panel under mesh tool click smooth vertex

enter image description here

Then convert the tris to quad go to Mesh > faces > Tris to Quads (Alt+J) enter image description here

enter image description here

| improve this answer | |
  • $\begingroup$ Thanks for the detailed answer :) Turning off the auto smooth seems to be doing the trick. Why is auto smooth have a problem with subdivision? I like the effect of auto smooth on the rest of my model. I wonder if there is any way to subdivide with this feature on? $\endgroup$ – Chris Apr 14 '17 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.