0
$\begingroup$

Once again, I am writing my game collection with common engine. This time I have worked with ASSIMP-based asset loader. To test the loader and rest of the framework, I have fetched few models and tried them out.

Now, one of the models behave strangely. If I load the original Wavefront .obj to blender, it shows it just fine:

Purple Giana original

Then, I scale it smaller, and try to export it in various formats (.dae, .obj). In this process, something happens: when I load the exported .obj (or .dae) back to Blender, it looks like this:

enter image description here

I have tried to load it with my current loader, and it looks just the same. It does not matter if I export it as .obj or .dae. It didn't help that I saved the original one as .blend, and then tried to export the model from that (note: both original and saved .blend file load normally to Blender).

I am currently bit out of ideas to get it loaded correctly (to Blender and/or to my game project), I have tried like everything (flipping UVs, correcting normals on both Blender and ASSIMP, converting it to left-handed on ASSIMP and so on, and so on). I am pretty sure the solution is simple, just can't figure it out :/


I'm using Blender 2.78, Linux Mint 18.1 64-bit. The model was loaded from here: http://tf3dm.com/3d-model/puo-3998-36657.html

$\endgroup$
  • 1
    $\begingroup$ The mesh has custom normal data (see in the data property panel, on the geometry data section "clear custom normals"). So I guess this is not correctly exported or imported (or if it is, it need some options to be activated). $\endgroup$ – lemon Apr 12 '17 at 16:59
  • $\begingroup$ Ah, found it, half-way there already :) Not yet able to load it to demo viewer correctly, but bit better, thanks! $\endgroup$ – MaKo Apr 12 '17 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.