0
$\begingroup$

Even when I put AV sync in the option, it seems to go out of sync at any time. Also, even when I put a full video in Blender it cuts it off. How can I fix this?

$\endgroup$

1 Answer 1

2
$\begingroup$

A video strip is a sequence of still images, the time it takes to play them is determined by the number of frames played per second. The closest an audio clip has to fps is samples per second, so is always played based on a time measurement.

By changing the frame rate setting in the render settings, you vary the length of time the video strip takes to playback but not the audio, to keep the video and audio in sync you need to have the frame rate match the original video settings.

The easiest way to know that the frame rate is wrong is in the sequencer, the video and audio strips will only be the same length if the frame rate is correct.

bad frame rate

To get the audio in sync with the video, set the correct frame rate. If the video stops early that means you need to increase the end frame to match the length of the video.

render settings

When you add a video strip to the sequencer there is a Use Movie Framerate option that will set the frame rate to match the video for you but you will still need to set the desired end frame.

add video options

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .