1
$\begingroup$

rigify generate my rig like "not in the right place", it doesnt generate it right at the meta rig position. i've set the meta rig origin to the centre (didnt work) and also beteen the leg(even worse). sometimes the rig itself doesnt even show up when i generate it. there's a error report at top-right corner, like this enter image description here

as you can see, the rigify generate the rig above the meta rig, and the report a"auto-run disabled....." any solutions ?

$\endgroup$
1
$\begingroup$

That is a security feature, click the "Reload Trusted" button right to the error message. To permanently allow script execution change the user pereferences accessible from the file menu:

enter image description here

Auto-run scripts security options

$\endgroup$
  • $\begingroup$ the error is gone though the generated rig still doesnt match the meta rig position. i still have it above the meta rig position, any solutions to that ? $\endgroup$ – Jass Kick Apr 8 '17 at 11:42
  • $\begingroup$ from your screen shot I can only see that the 3d cursor isn't at the center. Before generating anything try to place all objects at the center and make sure that scale is applied. If this doesn't help consder uploading your .blend file. $\endgroup$ – stacker Apr 8 '17 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.