Is there a way to prevent a single object from casting shadows? If I shut down "Cast Shadows" on the light source then all shadows will be lost. That is not what I want. I want to be able to prevent a single object from casting shadows.

A use case may be a laser. If I were to use a cylinder to model my laser, and that laser was positioned between a wall and a light source it will cast a shadow on the wall, but it should not cast a shadow.

  • $\begingroup$ I recommend breaking this kind of post into several different questions. You are free to place as many questions as you want, but we prefer if you keep each post to a narrow subject (this also helps other people searching for solutions) $\endgroup$ – zeffii Jun 9 '13 at 17:24
  • 5
    $\begingroup$ Is this a rant or a question? $\endgroup$ – iKlsR Jun 9 '13 at 17:42
  • 3
    $\begingroup$ There are some valid questions in there, but they should be submitted separately. The rest of this does not belong as a question on stack exchange, it's more suitable to a discussion forum like blenderartists. $\endgroup$ – brecht Jun 9 '13 at 17:58
  • $\begingroup$ Ok, which ones do you consider valid? $\endgroup$ – 00Ghz Jun 9 '13 at 19:29
  • 2
    $\begingroup$ You just need to split up your questions, check other questions here that are voted up, if you want to discuss many topics at once and general workflow issues, use a forum. $\endgroup$ – ideasman42 Jun 9 '13 at 20:43

Objects not casting shadows? easy, un-tick the shadow box.

enter image description here
In Cycles 2.79+, Ray Visibility was renamed to Cycles Settings.

As for the lighting, Cycles simulates the physical behaviour of light with some reasonable accuracy. All techniques used in real photography can be applied to lighting setups in cycles, The video also discusses the composite of various render passes, I think you'll find they are all possible in Blender. Be specific about what you want to know and you will get accurate answers.

  • $\begingroup$ Thanks, one less thing to worry about. Ok, next thing. What about making a light cast only specular like in the video? Is that the Glossy option? $\endgroup$ – 00Ghz Jun 9 '13 at 17:50
  • 5
    $\begingroup$ @00Ghz you can ask several questions here so feel free to ask, each post should have only one question to limit the scope. $\endgroup$ – iKlsR Jun 9 '13 at 18:01
  • $\begingroup$ In Blender 2.79, this is under Material >> Shadow >> Cast $\endgroup$ – Regular Joe Jul 31 '18 at 17:55

Cycles, Blender 2.79

Select the object, and in Properties / Object / Cycles Settings, disable Shadow.

shadow settings

  • $\begingroup$ How is this answer different from the existing answer, except for bold text and a larger screenshot? $\endgroup$ – Leander Dec 23 '18 at 20:11
  • 1
    $\begingroup$ @Leander "Ray Visibility" in the other answer looks like a section that doesn't exist in 2.79 $\endgroup$ – qubodup Dec 23 '18 at 20:16
  • $\begingroup$ The section was renamed, I edited the other answer. You can also suggest edits to other answers to improve them anytime. $\endgroup$ – Leander Dec 23 '18 at 20:24
  • $\begingroup$ The comment by Regular Joe made me think the answer might be something different because materials were mentioned. Thus decided to make new answer. I'd suggest updating screenshot or splitting your answer into two for different version/(ranges?) with # headers. cheers $\endgroup$ – qubodup Dec 23 '18 at 20:30
  • $\begingroup$ Sounds legit, I'll add some images later. $\endgroup$ – Leander Dec 23 '18 at 20:34

For 2.8 and for rendering I found selecting the shadow mode to None to be working. It's under material settings.

enter image description here

  • $\begingroup$ What's the context for this screen? I can't seem to find a "Settings" panel like that anywhere. $\endgroup$ – Ajedi32 Aug 27 '19 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.