My issue is that upon startup, my Blender interface runs extremely slow. It takes 1+ seconds to process any mouse input--it takes over a second to move the mouse cursor from one point to the other, or to click on a single button.

I have used Maya, C4D, and 3DS Max and have never had this problem before. I tried opening Unity 3D and Maya, and they both run super fast on my gaming rig.

My Specs are:

Windows 10 AMD Six-Core Processor, 3.5 GHz 16GB DDR3 RAM 64 bit Os, x64-based processor NVIDIA GeForce GTX 750 Ti

I have seen very many posts on Blender Stack Exchange related to my issue, most notably, the ones with josepharaoh99 and KentZ, but none of them seem to solve my problem.

I have tried Right-Clicking on the Blender shortcut to "Run with graphics processor > Integrated Graphics," but the "Run with graphics processor" option is not displayed in the menu that appears when I right-click on the shortcut. I then tried to add Blender to NVIDIA Control Panel, but there is no option to do that.

Someone, anyone, please help me--I don't want to be doomed to a skipping-interface snail-paced Blender forever.

  • $\begingroup$ Seems like users with windows 10 are having issues with the drivers for Nvidia cards, try updating to the latest version, or maybe downgrading to a previous one woud work on your case, since your card is a bit older. $\endgroup$ – user1853 Apr 7 '17 at 13:54
  • $\begingroup$ What program would I do that through? GeForce Experience? Or NVIDIA Control Panel? For some reason, I don't see the options to downgrade through either program. Maybe I need to reinstall those? GeForce experience also won't upgrade my driver, the progress bar remains at 0%, 0.00 kbps per second--no matter what. 376.53 is my current driver version. Would downgrading back to Windows 8.1 help at all? $\endgroup$ – Cyrus Majidy Apr 7 '17 at 14:12
  • $\begingroup$ @CyrusMajidy If the app isn't allowing you to update, go and get the driver manually from nvidia's site. nvidia.com/Download/index.aspx $\endgroup$ – iKlsR Apr 7 '17 at 15:28
  • $\begingroup$ Yep, I did that, got NVIDIA's latest driver. However, I'm still trying to get to the point where I can right click on the blender shortcut and the "Run with graphics processor" option appears. I'm not there yet. $\endgroup$ – Cyrus Majidy Apr 7 '17 at 16:27

If you got the anniversary windows 10 update, it's going to be very buggy. It got to the point where Blender stopped launching for me then Windows completely crashed. I made a boot disk with this official tool https://www.microsoft.com/en-us/software-download/windows10. Made a fresh install. Now Windows runs incredibly fast and I have had no issues with Blender. Also freed up my main drive by 150gb.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.