4
$\begingroup$

Why do some faces in Edit mode when I have Faces selected do some of the faces not have black dots? When I try to subdivide those, it doesn't work properly (all that happens is the black dots of neighboring faces move closer to the selected face).

On further investigation, I found that the faces ended up facing inwards instead of outwards. Is there a way of easily fixing that?

Here's what is happening: enter image description here

| improve this question | | | | |
$\endgroup$
  • 3
    $\begingroup$ upload your blend $\endgroup$ – Vader Mar 12 '14 at 18:50
  • 2
    $\begingroup$ this definiteness a case of ngons. $\endgroup$ – Vader Mar 12 '14 at 19:05
  • $\begingroup$ use Ctrl + N to have the faces point outwards, note that is you have bad geometry this may not help. $\endgroup$ – Vader Mar 12 '14 at 19:14
  • $\begingroup$ It looks like you have a giant face going under the other faces across the top. This face does have a dot, but its in the middle underneath the other faces. $\endgroup$ – gandalf3 Mar 12 '14 at 19:36
  • $\begingroup$ Not the case as when I deleted those faces, there was no face underneath. $\endgroup$ – PixelArtDragon Mar 12 '14 at 19:37
3
$\begingroup$

The Face dot it drawn at the geometric center of the vertices that make up the face. If you are using Ngons you may not see it actually anywhere inside of the face.

enter image description here

Another possibility is that you face dots are too small. To increase the size you can go to the theme setting in the preferences.

enter image description here

As you can see here the Ngons are not subdividing.

enter image description here

| improve this answer | | | | |
$\endgroup$
  • $\begingroup$ Two things: The faces are very clearly convex shapes, so the center would be inside them. Other faces do not have the same issue, so it's not a problem of settings. $\endgroup$ – PixelArtDragon Mar 12 '14 at 18:50
  • $\begingroup$ GAh! Beat me to it ;-) Good answer. $\endgroup$ – Matt Mar 12 '14 at 18:51
0
$\begingroup$

EDIT: To solve backward normals, (in edit mode) select Mesh -> Normals -> Recalculate Outside. This will recalculate all the normals so they point outward, but only works on a fully manifold (completely enclosed) mesh.

EDIT: In your case, it looks like you have some coincident faces (two faces that share some or all of the same surface area), and several n-gons. The part of the leg on the bottom right is probably an n-gon that just doesn't look like it. You may have two vertices very close to each other that look like one vertex, which would mean that this face is attached to 5 verts, when it looks like only 4.

To solve most of these problems, remove doubles. This will combine any vertices that are so close to each other that they look like one vertex.

As for the coincident faces, you'll have to be really scrupulous about finding out exactly which vertices each face is composed of. You can select a face, Delete -> Faces Only and then rebuild the face the way you want it.

=== original answer ===

Standard polygons have 3 or 4 sides. In some versions of Blender, non-standard polygons (sometimes called n-gons) don't have their centers marked (as with these examples).

N-gons also don't subdivide the same way that other polygons do in Blender. If you subdivide an n-gon, then the new vertices just become part of the perimeter of the n-gon because they n-gon doesn't need to subdivide (and the algorithm doesn't know how to subdivide n-gons). This is why you just see the number of dots around the edge increase.

To solve this problem, you'll want to make the n-gon into a set of standard polygons (3 or 4-sided), which can sometimes be difficult, but is always possible.

Hope that helps!

| improve this answer | | | | |
$\endgroup$
  • $\begingroup$ I'm not so sure this is what is happening. These faces were created as a result of subdivisions of a square face, and started out (before some vertex editing) being square. $\endgroup$ – PixelArtDragon Mar 12 '14 at 18:55
  • $\begingroup$ That's useful to know. You can turn on face normals in the view settings, to be sure. I've updated my answer. $\endgroup$ – Matt Mar 12 '14 at 19:02
  • $\begingroup$ ...although "some vertex editing" is exactly when the problem of duplicate verts and inadvertent n-gons would have been introduced ;-) $\endgroup$ – Matt Mar 12 '14 at 19:04
  • $\begingroup$ Well, I tried both of these to no avail. I could probably just delete the relevant faces and rebuild them, see if that works. $\endgroup$ – PixelArtDragon Mar 12 '14 at 19:07
  • $\begingroup$ Oh well, that didn't help either. $\endgroup$ – PixelArtDragon Mar 12 '14 at 19:10
0
$\begingroup$

I had a similar problem and went for the nitty-gritty solution. I selected the aberrant face in face mode. Pressed X and deleted the face. Then in vertex mode I selected the corners of the face and pressed F to create a new face. The new face subdivided as required.

| improve this answer | | | | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.