0
$\begingroup$

I exported this CAD model from a SolidWorks assembly using eDrawings in STL format, then imported into Blender:

enter image description here

enter image description here

As you can see there is alot of bad geometry. I have already done the following:

  • Removed any double vertices
  • Converted Quads to Tris with ALT+J
  • Mesh -> Clean Up -> Degenerate Dissolve

But I'm still left with a bit of a mess. Adding a Decimate modifier in Planar mode might be able to fix some of this but I will still be left with a less-than-perfect mesh.

Any tips on how I can make this any better? The model will be UV-unwrapped and imported into Unity.

$\endgroup$
  • $\begingroup$ Have you tried a Remesh modifier? They aren't perfect, and can be a pain to tweak right, but you might get more useable geometry by combining one with a Decimate modifier set to Unsubdivide. $\endgroup$ – Scott Milner Apr 6 '17 at 19:57
1
$\begingroup$

If you mean less than perfect in term of the exact volume, than this is problematic for numerical reasons already. A treshold is needed at some point to determine which edges can be removed.

The order in which you use the operations play a major role. As you mentioned, the Decimate Modifier in Planar Mode is probably your best bet for this. Note that dissolving and decimating will be similar in this case, but I would try Decimate first and then Dissolve in the next step.

Also don't use Convert Tris to Quads before using Dissolve or Decimate, it will make the geometry more messy. It should be the last step and probably guided by hand. Selecting some important loops and using sharp/seem edges will help to get cleaner Quads. Check Compare Sharp or Compare Seam.

`Beautify Faces" might help, but might make it worse aswell. Trying can't hurt.

You might also play with the export settings and try a different file format in SolidWorks.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.