2
$\begingroup$

On a project I was working on creating shape keys and sculpting the model for those keys, suddenly while attempting to create a new shape key some of the vertices of the model stopped reacting to the sculpt mode brushes and won't move at all. I was able to sculpt the same vertices earlier for the other shape keys and they still move if I change their weights. I tried all of this to try to figure out what's going on:

  • Isolated the "frozen" vertices by deleting all the other ones.
  • Deleted all other objects and modifiers in the project.
  • Deleted all the shape keys
  • Extruded some of the frozen vertices (by extruding edges) to create new geometry
  • In edit mode added a UV sphere as part of the same object where the frozen vertices are

The frozen vertices and the newly created by extrusion remained frozen and impossible to alter by any of the sculpt mode brushes. I was able to sculpt the newly created sphere without any issues.

I then applied a modifier to the object with the frozen vertices (tried with subdivision or with bevel) and this un-froze the vertices and I was able again to sculpt them. Is the vertex data corrupted? Is there a way of fixing this in the full project (I can't apply modifiers without loosing all my shape key work)?

Project file with the frozen geometry (can you sculpt this?): Blender file

$\endgroup$
2
  • $\begingroup$ I found a workaround but not a solution. If I export my scene as FBX and import into a new Blender project the vertices move normally again. I'm still wanting to find a reason why this happened, in case I run into the same issue another time and FBX exporting is not an option. Also I want to know from the community if anyone has experienced this before. It might just be a bug and if it is I'll report it as such. $\endgroup$
    – hcenteno
    Commented Apr 4, 2017 at 15:06
  • $\begingroup$ Happened to me too. The mesh edge was tuck, the only solution was to fill it than delete it after sculpt. $\endgroup$ Commented Jul 27, 2022 at 7:57

2 Answers 2

3
$\begingroup$

This vertexes are masked. https://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.64/Sculpting

Masks are used to "protect" parts of the model from being edited by the sculpting tools. They appear as darkened areas of the mesh. The darker a masked area is, the less effect sculpting on it will have. Masks can be edited with the mask brush, as well as cleared or inverted accross the entire model. The masking feature is active as soon as sculpt mode is entered; there is no separate toggle.

To clear mask use Alt+M

enter image description here

$\endgroup$
0
$\begingroup$

In my case it was because I had accidentally enabled an auto-masking option in the header of the 3D viewport while sculpting. The "Cavity" one especially can get pretty messy with default settings.

Auto-Masking settings in the 3D viewport header Auto-Masking settings in Brush Settings

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .