I am completely new to blender however have to use it for a university project. Every time I render my image its not giving me the option to save (as you can see in this screenshot). Can anyone please help/tell me why this is happening? There is lighting in the scene so I'm not sure whats going on.

Thanks in advance help

  • $\begingroup$ Perhaps you were hovering over the menu before the image was finished rendering. If so, click away from the menu, then click Image again. $\endgroup$
    – JakeD
    Apr 2, 2017 at 19:01
  • $\begingroup$ @pycoder I've just tried that but its still not giving me the option to save unfortunately; I can imagine it's going to take quite a while for me to work out the program $\endgroup$
    – Nina
    Apr 2, 2017 at 19:14
  • $\begingroup$ maybe - blender.stackexchange.com/questions/15293/…. Generally it should work like - if image doesn't exist on disk yet, then Save As is available; if exists - then both. $\endgroup$
    – Mr Zak
    Apr 2, 2017 at 19:40
  • 1
    $\begingroup$ What happens if you press F3 while hovering the image? $\endgroup$ Apr 2, 2017 at 19:50
  • $\begingroup$ @MrZak That hasn't worked but I've managed to save it by creating a new render copy. I just pressed the little grey plus sign and for some reason its gave me the save as option in the new screen! Thanks very much for your help! $\endgroup$
    – Nina
    Apr 2, 2017 at 20:10

1 Answer 1


I know a answer, but it may not work.

  1. Set the file output destination and image format as you would normally do.
  2. Edit both starting frame and ending frame of your image to the frame of which you want to render (ex.: I want the frame 260 to be rendered as an image, I put the starting frame and ending frame to 260). You can edit it in the render menu somewhere or in the timeline
  3. Click on the RENDER ANIMATION and not the RENDER IMAGE. Because when you make the file output an image file and put the animation render, you get a image of each frame, thus setting the frame start and end will make it render only that frame. I'm not sure if it will work for you, and it may not apply transparency.

render settings in blender


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.