1
$\begingroup$

I've been trying to model a vintage light bulb, but the filament seems to produce a lot of noise and result in a pixelated render. I think it has something to do with the glass material, since the filament looks fine without the bulb material. It could also have to do with the high number of polygons in the filament. I've tried different samples numbers and emission strengths, as well as different glass/transparent node mixtures for the glass, but it always seems to come out looking noisy and pixelated. Any ideas?

enter image description here

I adjusted the glass material to be more transparent, which meant I could reduce the emission strength of the filament. It's looking better, but still pretty grainy (Forgive the lower poly preview of the bulb, but I'm mostly concerned about the appearance of the filament and the wall right now). I haven't been able to effectively reduce the fireflies with clamping. I also tried adding a fake point light source but kept ending up with unwanted reflections off the glass, so I took it out (there's probably a way to get rid of these through the node editor, but I couldn't figure it out). My next move might be to try to use the wider dynamic range color management (Filmic Blender).

I did crank up the samples to 2000 AA samples with 6X as many for diffuse and glossy, and 3X as many for transmission. The fireflies became so numerous that they are now the majority (evidently the entire wall was supposed to be brighter), but the filament and its reflections still look like a crazy mess.

Should I crank up the Mesh Light samples? Or is the filament doomed to look crazy because of my resolution and/or because of the limited dynamic range of the sRGB color space?

enter image description here

$\endgroup$
1
$\begingroup$

I'll give a stab at an answer to my own question. Turning up the emitter as high as I had it caused the filament to become overexposed, and taking a hint from other folks who have rendered vintage light bulbs (e.g., https://www.cgtrader.com/3d-models/furniture/lamp/vintage-edisson-light-bulbs-collection), it's probably better not to overexpose the filament. Here's an example of rendering the bulb at 500 AA samples with some external lighting to illuminate the bulb exterior. Not quite the same atmosphere I was going for, but it's WAY cleaner looking. Apparently backwards ray-tracing to a complex filament is just a tricky thing to do, all the way around.

enter image description here

Another interesting find is that the blackbody converter node actually changes the color of the emitter now that the emitter strength is 1. With the really large values I had been using, the color usually washed out to white anyway.

$\endgroup$
  • $\begingroup$ To deal with higher dynamic range like you need to deal with emitters like this look into using the filmic blender OCIO configuration: blender.stackexchange.com/questions/46825/… $\endgroup$ – cegaton Apr 7 '17 at 22:52
  • $\begingroup$ Another trick to deal with the emitter being not as bright to the camera but light all around, is to create another emitter node and control it through a light path node-is camera ray, so that it is not visible to the camera but to everything else. See: blender.stackexchange.com/questions/43248/… $\endgroup$ – cegaton Apr 7 '17 at 22:54
  • $\begingroup$ Gotcha. Thanks for the suggestions. The emitter idea is clever, though I'm a bit leery now of turning up the strength of this filament, as it seemed to produce a lot of fireflies. But maybe now that I have the external lights as well, it would be okay. $\endgroup$ – Josiah Bryan Apr 12 '17 at 1:53
1
$\begingroup$

I love mesh lights so I use Branched Path Tracing & the Light Paths settings to get rid of fireflies and noise.

I get good results in most situations by, in the Sampling Panel, choosing Branched Path Tracing and setting Clamp Indirect to something between 0.1 and 0.5 and setting the Mesh Light Samples to 3ish.

In the Light Paths Tab, I set Max Bounces, Diffues, Glossy, and Transmission to 2. Lastly, you can check Denoising in the Layers tab to clean up any remaining noise. I just leave the defaults.

Attached pic has at least 7 mesh lights and used only 250 samples.(So you can still see some denoising artifacts, but for super low samples, not bad.)

enter image description here

$\endgroup$
  • $\begingroup$ Nice, thanks so much for the answer! That does look really good. I think my issue may have been using the mesh light inside of a transparent bulb. Maybe there's a way to do that well too, though. $\endgroup$ – Josiah Bryan Mar 10 '18 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.