2
$\begingroup$

I am using 2.70 with Cycles to recreate Ian McGlasham's "Alice Blender Fluid Cycles".

However, for some reason my fluid does not fill the entire text -- for some reason it only fills part of the text:

enter image description here

Previously, this gap was much larger and I made the gap much smaller by increasing the Final Resolution of the domain object from 65 to 200. This was a HUGE improvement, so I assume maybe I need to increase the Final Resolution even more to have the fluid finally touch the walls of the container. However, when I see how finely the fluid mesh is already divided, it's surprising that's not enough resolution/faces to be able to conform fully to the container walls.

Since the fluid mesh looks like it should have enough resolution (small enough faces) to conform to the shape of the container, I am wondering if maybe I need to change the Surface Smooth and/or Surface Subdivisions settings in the Fluid Boundary section, or do they need to be used at all? As you can see in the picture, I have Surface Smooth set to 1.0 and Subdivisions set to 3. I read that increasing these can greatly increase the render time and may also cause Blender to crash if you run out of RAM, and I only have 2GB of RAM.

So, in order to get the fluid to fully conform to the container, do you think I should:
- increase the Final Resolution
- increase the Surface Smooth
- increase the Subdivisions
- or some of each, and if so which ones

Also, do I need to have the Surface Subdivisions set to 3 or can I turn that back down to 2 or lower? It takes so long to bake on my computer that I'd love to understand these settings and not have to learn by days and days of trial and error, so any help would be greatly appreciated!

Thanks!

Also, here is my current blend file.

$\endgroup$
  • $\begingroup$ Ian McGlasham here. If you are still playing with this I am happy to send you the original blend file. leave a message via my photography website with your email address and i will send it to you. www.ianmcglasham.com. Cheers. Ian. $\endgroup$ – user15094 Jun 19 '15 at 9:52
3
$\begingroup$

The issue is (as already pointed out by Vader) your mesh is not manifold, basically meaning that it can't exist in the real world.

You can select non-manifold geometry by pressing CtrlShiftAltM in edit mode:

enter image description here

The reason all those edges are selected is because your mesh as no thickness. This will cause the fluid simulator (and a good many other things) to have problems.

You can partially fix this situation with a Solidify modifier (note that modifiers must be applied for the fluid simulator to take them into account), however there are still a few other problems.

I think you are better off starting over than trying to salvage this mesh, as even with the solidify modifier I don't think it will do what you want (I assume you want to have fluid everywhere except inside the letters).

An easy way to make hollow manifold text is by setting the Fill to None and adding a solidify modifier.

$\endgroup$
  • $\begingroup$ Thanks for pointing out the importance of making the mesh a manifold...I had no idea how important that is. So, I've been studying manifolds now and I've discovered the key seems to be to make sure "Automatically merge vertices moved to the same location" is enabled when editing the mesh. You probably knew this, but I'm just putting it here in case someone else reads this and would like to know how to make sure the mesh stays manifold. Do you have any other suggestions on how to make sure the mesh stays manifold (before adding a Solidify modifier)? :) $\endgroup$ – Thom Blair III Mar 12 '14 at 13:56
  • $\begingroup$ I'm also exploring why Remove Doubles sometimes works and sometimes doesn't work for making the mesh a manifold. $\endgroup$ – Thom Blair III Mar 12 '14 at 14:06
  • $\begingroup$ It seems Remove Doubles won't work if there aren't two vertices together. So, when I have a solid edge that overlaps a subdivided edge, Remove Doubles won't merge those two edges together, thus leaving the mesh non-manifold. It seems what I'm needing is a feature like "Merge vertices, edges and faces in the same location" so that the solid edge could somehow be merged with the subdivided edge easily. Is there a way to do this? Or am I missing the point? $\endgroup$ – Thom Blair III Mar 12 '14 at 14:24
  • $\begingroup$ In case I wasn't clear, here's a picture: drive.google.com/file/d/0B_yQeQQ8ImENTmxLaGRiNVAwWG8/… Here the non-manifold areas are selected. When I extruded edge A along the X axis (red arrow), it created the face with the solid edge B. This edge B overlaps some pre-existing vertices like the ones circled in yellow. So, is there an easy way to merge edge B with the pre-existing vertices either while extruding or after extruding? $\endgroup$ – Thom Blair III Mar 12 '14 at 15:02
  • $\begingroup$ @ThomBlairIII It looks like a bit of a mess as far as I can tell.. I think you'll just have to clean it up manually with loop cuts and the knife tool (though be careful that you don't accidentally create ngons). $\endgroup$ – gandalf3 Mar 12 '14 at 20:01
1
$\begingroup$

As you pointed out there is not domain in your fluid simulation. You need to have a domain to simulate fluids, smoke and liquids. The other thing that might be a problem is that fact that your mesh is non-manifold, the mesh is absolute filthy. There are overlapping edges, stray verts and most importantly the mesh is not water tight, meaning the water does not know what side of the mesh is inside or outside. I will update my answer

$\endgroup$
  • $\begingroup$ I know I need a domain. I've tried many different ones but I thought maybe I'd messed up the domain so I deleted it from the file. If you think it's a good idea, I can upload a blend with a domain. As for the mesh, I know it's not expertly made -- it's one of the first meshes I ever made, long before I learned about snapping to and merging vertexes. I knew there are overlapping edges, but is that a functional problem (i.e. will that prevent the water from flowing properly) or is it simply an aesthetic problem? $\endgroup$ – Thom Blair III Mar 11 '14 at 18:28
  • $\begingroup$ Also, how can I find out where the mesh is not water tight? $\endgroup$ – Thom Blair III Mar 11 '14 at 18:29
  • $\begingroup$ Thanks for pointing out "stray verts"...I'd never heard of them before. So now I'm reading about them and about optimizing models. $\endgroup$ – Thom Blair III Mar 11 '14 at 18:37
  • $\begingroup$ use Ctrl Shift Alt M in vertices mode, it will select all bad topology $\endgroup$ – Vader Mar 11 '14 at 18:43
  • $\begingroup$ I used CTRL SHIFT ALT M and it selected most of the vertexes in the letters. Is this because I created the letters by converting a text object to mesh? I think I recall that in Blender, extruded text does not convert to a manifold mesh. Is that correct? If so, what do I do with such a huge number of bad vertexes? Should I just start over with properly formed manifold text? $\endgroup$ – Thom Blair III Mar 11 '14 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.