10
$\begingroup$

I try a simple particle system, with this group on the layer 2 : the group

The result, placing it at Vertices places on a grid, using this group, is like : the result

The problem is that sometimes 2 or 3 objects are at the same time on the same place... I didn't found anywhere how to disallow that, I would like to have just 1 object at random places (less or equal to the number of vertices) Thank you !

blend file

$\endgroup$
7
$\begingroup$

I think this way may meet your needs:

enter image description here

See key settings marked in the image above, very intuitive I suppose.

$\endgroup$
  • $\begingroup$ I really need it to be on vertices (probably on a more complicated surface), not necessary like a grid, and not on faces :( $\endgroup$ – Mizur Mar 8 '14 at 19:04
  • $\begingroup$ Sure, as I said, then change it to Verts as you want, and set an appropriate emit number. Is that OK? $\endgroup$ – Leon Cheung Mar 8 '14 at 19:17
  • $\begingroup$ No, that is why I asked : I set a certain number of objects to be on vertices, but sometimes they overlap. If I disable "Random" (as said with Vader in the other answer) the objects are placed in a certain order (I can enable Pick Random). When I populate all the grid this is OK, but when I just want, for example, to create 50 objects on 100 vertices, I obtain without Random : img15.hostingpics.net/pics/910957bb1.png With Random : img15.hostingpics.net/pics/596547bb2.png overlaping :/ File uploaded in question $\endgroup$ – Mizur Mar 8 '14 at 19:24
  • $\begingroup$ I've updated my answer. Then why not enable Pick Random while disable Random? The new way I suggest allows you to randomly pick vertices on the mesh by vertex group, if that's what's acceptable. $\endgroup$ – Leon Cheung Mar 8 '14 at 19:29
  • 2
    $\begingroup$ OK. A small tip: you can randomly select expected number of vertices by the Select Random function, then Hit F6 to adjust the percentage value, the total number of selected vertices can be monitored simultaneously in the top Info bar. Good luck. :) $\endgroup$ – Leon Cheung Mar 8 '14 at 19:45
3
$\begingroup$

Disable Random in the particle emitter tab. This will only use each part once as long at there are not more part than there are particles.

enter image description here

Also if you are emitting from Verts or Faces you need to limit the number of particles and you want to populate the entire mesh:

  • Verts: number of verts in mesh + 1

  • Faces: number of faces in mesh

I am not sure why but for Verts you need to add another 1 so that all verts have some mesh on them


enter image description here

blend file

$\endgroup$
  • $\begingroup$ Thanks for your answer :) but I probably misspoke, I want it to be random (less or equal to the number of vertices), without more than 1 object to be at the same place, is it possible ? $\endgroup$ – Mizur Mar 8 '14 at 16:47
  • $\begingroup$ you mean that you want the number of particles emitted to be random? $\endgroup$ – Vader Mar 8 '14 at 16:49
  • $\begingroup$ no I mean for example I have 100 vertices on my grid. But I only want to put 50 objects on some vertices (I did it on the screenshots of my question), the problem is that sometimes more than 1 object is put on the same vertices, I don't want it. Moreover if I disable Random in the particle emitter tab, objects are put in the order ; one green, then one brown, then one purple, repeated. I want it random, on random places. $\endgroup$ – Mizur Mar 8 '14 at 16:54
  • $\begingroup$ @Mizur for me it does them randomly. I will upload a screenshot $\endgroup$ – Vader Mar 8 '14 at 16:59
  • $\begingroup$ It is what happen when you disable Random ? (I guess no) never overlaping each other ? $\endgroup$ – Mizur Mar 8 '14 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.