3
$\begingroup$

This question already has an answer here:

A collegue of mine has created a model with SketchUp and I want to import it into blender now. He created several formats from the model(*.3ds, *.dae, *.obj) which I can import. However, I always do not seem to get the correct dimensions for the objects after the import. Also, depending on which format I choose to import, the dimensions are different.

So, there are two options now. Either, the dimensions get broken when he does his export. Or Blender fails to import correctly.

How can I rule out the second option? How do I import respecting the dimensions of the object from either *.3ds, *.dae or *.obj?

The current situation when importing from *.ds looks like this: One of the models should have dimensions of about 2,10m length and 1,10m width. In Blender's object mode:

enter image description here In edit mode with edge length enabled:

enter image description here

Why are the dimensions so different? Even the ratio of the sides is off in object mode.

edit: When I import from *.dae the dimensions in edit mode are correct but not the ones shown in object mode. What is the difference between the two in the first place?

$\endgroup$

marked as duplicate by cegaton, Denis, Duarte Farrajota Ramos, Timaroberts, David Mar 24 '17 at 22:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2
$\begingroup$

I just did an experiment:

Created a 2 meter cube in Sketchup Make 2017.

Exported as a.dae file.

Imported to Blender.

enter image description here

enter image description here

After Applying the scale in Object mode the dimensions were correct.

enter image description here

enter image description here

I have no idea why the imported cube was scaled to 0.025 but maybe something similar is happening with your imports.

If the scale is not 1.0 in the X, Y and or Z then try applying Scale.

In Object mode: with object selected, Ctrl + A to open Apply menu.


If you do some maths on the edge lengths of 78.74 shown in edit mode of the "2x2x2m cube" (before applying Scale) (see second image in previous post) you will notice:

78.74 / 2 = 39.37 (Divide by 2 to find length for 1 meter)

39.37 x 0.025 = 0.98125 ( multiplied by 0.025 because that is the scale showing in Object mode. See the first image in my previous post. This is very close to 1 meter.

The Scale of 0.025 reminded me of the number you get when converting inches to metric. 1 inch = 0.0254 meters.

I know almost nothing about collada files but do know you can open them in a text editor and have a look inside.

This is what the first few lines of the 2 meter cube exported from Sketchup look like.

enter image description here

And this is the first few lines of the collada.dae file of a 2 meter cube created and exported from Blender as a Collada.dae file:

enter image description here

Perhaps you need to find some setting in the Sketchup exporter setup to correct this?

Or maybe you could try editing the unit line in the Collada file so that it reads the same as the the Collada file exported from Blender.

No I am not a sketchup user, I just had it on my computer because a a while ago i wanted to see how it works.


I noticed that in the Blender Collada Import menu there is an Inport Units option.

enter image description here

enter image description here

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Hi! I added some pictures to show the current situation i am in more clearly. When you correct the scale, how do the "dimensions" in object mode change? $\endgroup$ – user1809923 Mar 23 '17 at 7:44
-1
$\begingroup$

.obj files that I've seen, import as centimeters. So 100 = 1 Blender unit.
You may need to scale by 10 or 100 to bring it into a viewable size.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.