0
$\begingroup$

In Window, I installed python3.6 and, installed matplotlib by commandline:

pip install matplotlib

After installation, I was running matplotlib in python console,

import matplotlib.pyplot as plt --> not error
import matplotlib.pylab as plb --> not error

In python36\lib\site-packages

site-packages

I want in blender to use the matplotlib library in python, Can I copy the matplotlib in python36\lib\site-packages of Python into the Blender\2.78 \python\lib\site-packages?

I tried copying but only importing matplotlib, but when `import matplotlib.pylot as plt the error is as follows

errors

I do not know how to fix it, please help me

Thank you so much!

$\endgroup$
  • $\begingroup$ Did you try to remove blender's embedded python and fall back to the default python on your windows system? I've been using this method for a while and it hasn't disappointed yet (using Matplotlib among many other packages in Blender). $\endgroup$ – TLousky Mar 22 '17 at 9:42
  • $\begingroup$ I removed /blender/2.78/python folder, but can not open blender $\endgroup$ – kapigon Mar 22 '17 at 9:46
  • $\begingroup$ You must have a default python on your windows machine which is exactly the same version as the one Blender is using $\endgroup$ – TLousky Mar 22 '17 at 10:01