0
$\begingroup$

I am trying to render my scene (F12) and after two minutes I get the error shown below.

enter image description here

However, when I render the preview, it seems to have no problem.

enter image description here

How can I fix this problem?

Using Blender 2.78c + Win10
Render Settings

enter image description here

Let me know if any more information is needed. I'm still trying to get the hang of blender

The Blender file and normal map

$\endgroup$
  • $\begingroup$ You might have run out of memory on your GPU. Try switched to CPU and see if it renders at all. If it does render you need more ram on your GPU. $\endgroup$ – icYou520 Mar 20 '17 at 20:59
  • $\begingroup$ @icYou520 Is there a particular reason it would render the preview on the gpu but not the final image? $\endgroup$ – Dan Mar 20 '17 at 21:00
  • $\begingroup$ The preview is just a quick view it doesn't take in to account all the calculations needed for your scene. When you do a final render that's when ALL the math is calculated, taking up more memory. Your preview is set to 32 and your final render is set to 200. $\endgroup$ – icYou520 Mar 20 '17 at 21:02
  • $\begingroup$ It looks like your memory peaked a little over 4GB. So if you only have 4GB of ram on your GPU thats why it would give you the error. This usually happens to me when I use a lot of hi res textures. But it could be a number of things. $\endgroup$ – icYou520 Mar 20 '17 at 21:03
  • $\begingroup$ @icYou520 So it turns out that it did eventually render using CPU but I am a little confused to as why my GPU was using all 4GB to render what appears to be a relatively simple scene. Thanks $\endgroup$ – Dan Mar 20 '17 at 21:10
4
$\begingroup$

The difference and reason why it renders in previw and not in render is this setting:

enter image description here

In render the surface gets divided a lot more, so the geometry takes a lot of VRAM. Your scene takes 4.2 GB of it in render.

Also many other modifiers have separate settings for viewport/render, there may be objects hidden from preview etc.

Try to lower the quality till it fits in memory, or render on CPU or borrow/buy better GPU.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Thank you for your help. Just turning max subdivisions down to 4 fixed the problem $\endgroup$ – Dan Mar 21 '17 at 17:22
1
$\begingroup$

You don't have enough memory on your GPU. "CUDA Error: Out of Memory".

Try decreasing the number of vertex and/or lower the complexity of the scene.

EDIT again Can you make the .blend File downloadable? Also, take a look at this post: Cycles / CUDA Error: Out of Memory

It may help you.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Additional samples shouldn't increase memory. $\endgroup$ – PGmath Mar 20 '17 at 21:58
  • $\begingroup$ Ok, sorry for the error $\endgroup$ – Fabrizio Mar 20 '17 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.