0
$\begingroup$

I'm making this alarm clock, and after going to material mode from solid, it's not showing me the colors. Mine is like this enter image description here And colors are definitely there enter image description here Any help would be appreciated. Thanks :)

$\endgroup$
  • $\begingroup$ Have you applied any materials to your objects? If so do they have any color assigned? $\endgroup$ – Duarte Farrajota Ramos Mar 17 '17 at 16:34
  • $\begingroup$ Yes I have. I'm doing it from an youtube video and followed the instructions there. At first it showed colors, then I think pressed something, cause suddenly they r gone $\endgroup$ – Aisha Galaxy Mar 17 '17 at 16:41
  • $\begingroup$ help anyone???? $\endgroup$ – Aisha Galaxy Mar 17 '17 at 18:50
  • $\begingroup$ Well, Aisha, numbers are rendering in black... so colors are there... but could you upload your file in order to check if the same occurs in another environment? Please use this link to do that: blend-exchange.giantcowfilms.com $\endgroup$ – lemon Mar 17 '17 at 18:54
  • 1
    $\begingroup$ Here is the direct result for me: i.stack.imgur.com/3hQmK.jpg... so I don't know how to help... : ( $\endgroup$ – lemon Mar 17 '17 at 19:35
5
$\begingroup$

Ok here is the box you need to change. I think you got it wrong way round when you explain your issue too. You went from material to solid mode ... not the other way round I guess.

Basically, what's happening here is that. The solid mode is an opengl operation so it uses a different color operation for showing color on screen. Where material mode takes the material color into consideration. Solid mode are usually usually a quick way to set up simple color to work on the models before heading onto material creation.

enter image description here

And here is the same file with the colors changed!

$\endgroup$
  • $\begingroup$ It worked. Thank you and no, as I said I went from solid to material $\endgroup$ – Aisha Galaxy Mar 17 '17 at 19:37
  • 1
    $\begingroup$ ...mmm... I just don't get the point.. If I upload the file from @AishaGalaxy (in the comments above) I get the exact same result as the blend file in your answer. So.. why is it different for her? I'm not saying your answer is wrong.. just I do not understand it! $\endgroup$ – lemon Mar 17 '17 at 19:45
  • 1
    $\begingroup$ Color of the model in the viewport in material shading mode is driven with node settings; it doesn't depend on Viewport Color option in Settings rollout, so hard to guess the question then. $\endgroup$ – Mr Zak Mar 17 '17 at 19:47
  • 1
    $\begingroup$ If you go to solid mode in her file ... all the color of the object are grey. When I looked at the first image she posted, it's a mystery to me since it's showing that she is indeed in material mode. I have no idea why in the first place the colors did not show up. Maybe here installation of blender may have some issues to begin with. I am guessing $\endgroup$ – hawkenfox Mar 17 '17 at 19:48
  • $\begingroup$ I am startled to find that alot of people downloaded blender from unofficial build sites that have poor reputation. These versions are sometimes part of the reason why people experience issue with their installations. $\endgroup$ – hawkenfox Mar 17 '17 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.