0
$\begingroup$

I'm trying to create a lightsaber sword in blender and im using Volume Scatter for the glowing part of the sword. But the object with volume scatter is completly black. You can still see the sword inside but you cant see the handle because the volume scatter object is too dark and the handle is black. So is there any way to make the volume scatter object invisible?

Here is an image to show what im talking about Lightsaber Sword with Volume Scatter

$\endgroup$
1
$\begingroup$

First off, make sure that you have everything disconnected from the "Surface" node on material Output. enter image description here

And as a side note, an easier on render time way to make an emission object glow is to do compositing.

In the render layers tab, you can check 'emission' under passes.

enter image description here

Then just overlay a blur of the emission pass like this:

enter image description here

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Thank you, Good idea about the blur. I tested it and it worked. However, I was expecting the blur to showup in the 3d viewport but it only appears in render. It first renders the image without blur and when its finished rendering the image it adds the blur to it. It would be alot easyer to play with the different values if i could see it in the 3d viewport $\endgroup$ – Tim Levinsson Mar 17 '17 at 12:41
  • $\begingroup$ Thats how compositing works. If you want to play with it, you can checkbox 'Use Backdrop', and plug the last node into a viewer node. (This can be added through the 'Shift + A' menu. $\endgroup$ – Zac Perry Mar 17 '17 at 22:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.