I went to User Preferences > System panel to change my viewport anti-aliasing settings, but all I see is this column:

How my system panel is displaying.

I'm using Blender 2.78c, on Windows 10.

Here is what I'm expecting to see, screen-capped from an older version that I have installed (2.77a):

How my System prefs used to look.

I've tried uninstalling/reinstalling Blender and updating my graphic card drivers (Geforce GTX 980). I've also tried Loading Factory Settings without any luck.

Edit: I just opened the info panel up and I'm seeing this error, it seems like it might be relevant:

" Traceback (most recent call last): File "C:\Program Files\Blender Foundation\Blender\2.78\scripts\startup\bl_ui\space_userpref.py", line 433, in draw userpref.addons['cycles'].preferences.draw_impl(col, context) AttributeError: 'NoneType' object has no attribute 'draw_impl'

location: :-1 "

It seems switching to Cycles and making the Viewport Draw Mode as 'Rendered' causes Blender to crash.

Any help is greatly appreciated!


1 Answer 1


I was able to solve this by disabling the Cycles Render Engine in the Add-ons panel, this let me restore the System panel to how it should look.

enter image description here

As for getting Cycles to work again now, I'll ask another question...

  • 2
    $\begingroup$ If this is reproducible, I would highly recommend creating a bug report at developer.blender.org $\endgroup$
    – satishgoda
    Jun 7, 2017 at 11:27

Not the answer you're looking for? Browse other questions tagged .