I have been trying to render a simple glass of milk. Yet parts of the milk is not rendering. enter image description here Help would be greatly appreciated.


This partially looks like a Z-Fighting problem.

Try scaling up your Milk Mesh to where its perimeter edges are in the middle of the glass' inner and outer walls and try again.

To do this:

  1. Select your Milk Mesh.

  2. S.

  3. Shift + Z

  4. Move your mouse until it is lined up >> LMB.

Also, if this is still not working altogether after that:

  1. Select your Milk Mesh.

  2. Go into edit mode (TAB to toggle).

  3. A to select all.

  4. Ctrl + N to recalculate the normals.

    1. Go back into Object mode (TAB to toggle).

Now try rendering again. If it is still not working then hopefully we can get you to post your .blend file

After taking a look at your blend file, here is what I did to get the following results:

Glass Of Milk Results - 001

enter image description here 1. I applied your Boolean Modifier.

enter image description here enter image description here 2. I did the scaling step listed above.

enter image description here 3. I modified your glass material to that shown in the result image.

enter image description here 4. I added a Sun Lamp with a Strength of 5.0 (Using Nodes).

  • $\begingroup$ Thank you for your support but both of your solutions are not working. I will post my .blend file on dropbox: Glass of Milk.blend $\endgroup$
    – Alex12321
    Mar 15 '17 at 22:38
  • $\begingroup$ @Alex12321 - I've appended my answer for your review. $\endgroup$
    – Rick Riggs
    Mar 16 '17 at 1:23
  • $\begingroup$ I am new to this, what does that mean? $\endgroup$
    – Alex12321
    Mar 16 '17 at 1:23
  • $\begingroup$ @Alex12321 Dont thank for answers, upvote instead if they helped you, or mark them as accepted if they solved your problemm $\endgroup$ Mar 16 '17 at 1:26
  • $\begingroup$ It just means that I've added extra information to my answer, so that you can look at it, try it, and either mark it answered or express items that are still not working for you. $\endgroup$
    – Rick Riggs
    Mar 16 '17 at 1:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.