2
$\begingroup$

The "no objects or images to bake to" error I get when I try to bake. As you can see below it happens to only some objects even though the texture appears active.

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Internal uses face textures to bake images..image shown in UV/Image editor in Object mode doesn't mean it's active for selected object. So most likely cupboard has image assigned to its faces.. while object on the right hasn't. Checking that is done in Edit mode with all faces selected - if image is shown in UV/Image editor then it's assigned. $\endgroup$ – Mr Zak Mar 15 '17 at 12:12
  • $\begingroup$ I went to edit mode, made sure all face selected , re-selected the image in UV/image texture and even tried baking in edit mode but still the same error. $\endgroup$ – Venay Mar 15 '17 at 12:19
  • $\begingroup$ It works as I already mentioned. Aside from that before re-selecting image in UV editor select all uv islands and then remove image and assign it back. $\endgroup$ – Mr Zak Mar 15 '17 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.